Support » Plugin: Responsive Menu - Create Mobile-Friendly Menu » Can’t save settings change

  • Resolved Matt Scheidler

    (@matt6303)


    I am returning to a site I initially set up with your plugin about 3 years ago. I’m trying to make a settings change, but I am getting the following two errors when I click “Update Options”, and my changes are not being saved:

    Validation failed on Smooth scroll speed: Invalid number
    Validation failed on Single menu submenu line height: Invalid number

    I’ve tried deactivating/reactivating to no avail. I have not tried deleting and reinstalling. Will my configuration be retained if I would do so? All the rest of the settings are good except for the one I am wishing to change.

    If there’s another way to resolve this please let me know.

    Thanks for this plugin…I’m using it on several sites!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Peter Featherstone

    (@peterfeatherstone-1)

    Hey Matt,

    There is a way to do it but it requires knowledge of using your browser inspector tools and forcing the input to have a value, I’m not sure how comfortable you are with that.

    If you don’t know how to do that then I can do it for you buy you need to email me at support@responsive.menu

    I’m not sure why that setting didn’t save for you as it should’ve done, what version were you upgrading from?

    Please advise

    Peter

    Thread Starter Matt Scheidler

    (@matt6303)

    Peter,

    I continue to be amazed at your timely and accurate support, the few times that I’ve needed to reach out to you over the past few years.

    I changed “value” to “value=0” in both fields in the inspector, for the browser to validate, and my change saved perfectly.

    The site in question had been shelved for a couple of years; it was 2016 when I set up the plugin originally. I did skip several versions in a single update, to get back to the current version. If I need to make changes in the future, is this the best way to go about it?

    Peter Featherstone

    (@peterfeatherstone-1)

    Hey Matt,

    Excellent news and I’m glad you were able to do that first time.

    It’s likely that because you went up so many versions at once that the migration scripts weren’t able to run but I can’t confirm that is the case.

    In future the updates should be smoother now you are on the latest version but if you do have any issues please let me know.

    All the best

    Peter

    Hudson Santos

    (@smallbeecombr)

    The same issue here. The same bug showing:

    Validation failed on Smooth scroll speed: Invalid number
    Validation failed on Single menu submenu line height: Invalid number

    ..when trying to save settings.

    After doing what Peter suggested and Matt (@matt6303) did, it worked for me.

    Now: Responsive Menu Options Updated Successfully.

    Regards,

    Peter Featherstone

    (@peterfeatherstone-1)

    Hey Hudson,

    Excellent, good to see the forum working as intended!

    Peter

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can’t save settings change’ is closed to new replies.