Support » Plugin: WP Super Cache » Can’t save settings

Viewing 15 replies - 1 through 15 (of 15 total)
  • I’m running into the same issue, I can’t save WP SuperCache settings, in particular “Cache HTTP headers with page content.” I disable it, refresh, it’s still enabled. Tried with Chrome and Firefox and tried clearing all caches, browser-side server-side.
    Running latest WP, Wordfence in learning mode just in case as well.
    Using Simple mode, on NGINX.

    • This reply was modified 4 months, 1 week ago by vladdy.
    peterszky

    (@peterszky)

    How should I modify by hand the config file to enable debug log? The button also not working from the menu.

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    Are you using Expert caching? Change it to Simple caching as that may help. Then try disabling HTTP header caching.

    I’m using simple caching, “Cache HTTP headers with page content.” is in disabled status.

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    Any errors in your PHP error log?

    The functions that write to the config file haven’t really changed in a while. Can you grab an earlier version and tell me if you can update settings there?

    Go to https://wordpress.org/plugins/wp-super-cache/advanced/ and in the dropdown box select 1.6.6, and download it. Unzip and copy the wp-super-cache directory to wp-content/plugins on your WordPress site. You should overwrite your current install of the plugin. You might have to uninstall that version if you have any problems.

    I would be very interested to hear if that made a difference.

    I go to to the admin site – WP Super Cache – Debug – Enable button.

    In error log:

    [Mon Aug 19 20:21:35.263148 2019] [:error] [pid 13502] [client <IP>:40570] PHP Warning: rename(/var/www/<site>/wp-content/cache/wpsc992aIY.php,/var/www/<site>/wp-content/wp-cache-config.php): Permission denied in /var/www/<site>/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1263, referer: https://<site&gt;.hu/
    [Mon Aug 19 20:22:18.148151 2019] [:error] [pid 14223] [client <IP>:61534] PHP Warning: rename(/var/www/<site>/wp-content/cache/wpscwbXfqW.php,/var/www/<site>/wp-content/wp-cache-config.php): Permission denied in /var/www/<site>/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1263, referer: https://<site&gt;.hu/
    [Mon Aug 19 20:22:22.704805 2019] [:error] [pid 14625] [client <IP>:65376] PHP Warning: rename(/var/www/<site>/wp-content/cache/wpscg6P7l9.php,/var/www/<site>/wp-content/wp-cache-config.php): Permission denied in /var/www/<site>/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1263, referer: https://<site&gt;.hu/wp-admin/
    [Mon Aug 19 20:22:23.933558 2019] [:error] [pid 14716] [client <IP>:10840] PHP Warning: rename(/var/www/<site>/wp-content/cache/wpscJRblQc.php,/var/www/<site>/wp-content/wp-cache-config.php): Permission denied in /var/www/<site>/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1263, referer: https://<site&gt;.hu/wp-admin/
    [Mon Aug 19 20:22:24.975251 2019] [:error] [pid 14718] [client <IP>:11384] PHP Warning: rename(/var/www/<site>/wp-content/cache/wpscjAXuNf.php,/var/www/<site>/wp-content/wp-cache-config.php): Permission denied in /var/www/<site>/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1263, referer: https://<site&gt;.hu/wp-admin/
    [Mon Aug 19 20:22:27.328380 2019] [:error] [pid 14625] [client <IP>:65376] PHP Warning: rename(/var/www/<site>/wp-content/cache/wpsc0XnjkX.php,/var/www/<site>/wp-content/wp-cache-config.php): Permission denied in /var/www/<site>/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1263, referer: https://<site&gt;.hu/wp-admin/options-general.php?page=wpsupercache
    [Mon Aug 19 20:22:43.984540 2019] [:error] [pid 14698] [client <IP>:20958] PHP Warning: rename(/var/www/<site>/wp-content/cache/wpscL0FwK7.php,/var/www/<site>/wp-content/wp-cache-config.php): Permission denied in /var/www/<site>/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1263, referer: https://<site&gt;.hu/wp-admin/options-general.php?page=wpsupercache&tab=debug
    [Mon Aug 19 20:22:44.123775 2019] [:error] [pid 14698] [client <IP>:20958] PHP Warning: rename(/var/www/<site>/wp-content/cache/wpscuS33nH.php,/var/www/<site>/wp-content/wp-cache-config.php): Permission denied in /var/www/<site>/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1263, referer: https://<site&gt;.hu/wp-admin/options-general.php?page=wpsupercache&tab=debug

    I couldn’t do testing in production… (and I need to run this plugin 24/7) It’s a non-profit website, we don’t have a test node for it.

    • This reply was modified 3 months, 3 weeks ago by peterszky.
    Plugin Author Donncha Ó Caoimh

    (@donncha)

    @peterszky – I’m not sure what happened on your server but PHP doesn’t have permission to modify those files. It’s not the plugin. Did your hosting provider add some sort of security plugin that modifies how the server works?

    I don’t think so.

    -rw-rw-r– 1 ulloi129 ulloi129 656 szept 1 2017 advanced-cache.php
    drwxr-xr-x 2 ulloi129 ulloi129 4096 febr 17 2015 banners
    drwxr-xr-x 5 www-data www-data 36864 aug 20 10:03 cache
    -rw-r–r– 1 ulloi129 ulloi129 1761 júl 22 2017 debug.log
    drwxr-xr-x 2 ulloi129 ulloi129 4096 febr 17 2015 gallery
    -rw-r–r– 1 ulloi129 ulloi129 28 máj 6 2013 index.php
    drwxr-xr-x 4 ulloi129 ulloi129 4096 márc 22 23:45 languages
    -rw-r–r– 1 ulloi129 ulloi129 42560 máj 16 2013 login-logo.png
    drwxr-xr-x 21 ulloi129 ulloi129 4096 aug 16 21:09 plugins
    drwxr-xr-x 2 ulloi129 ulloi129 4096 febr 17 2015 reports
    -rw-r–r– 1 ulloi129 ulloi129 5935 máj 13 2016 tablepress-combined.min.css
    -rw-r–r– 1 ulloi129 ulloi129 155 máj 13 2016 tablepress-custom.css
    -rw-r–r– 1 ulloi129 ulloi129 136 máj 13 2016 tablepress-custom.min.css
    drwxr-xr-x 4 ulloi129 ulloi129 4096 máj 8 00:13 themes
    drwxr-xr-x 2 ulloi129 ulloi129 4096 aug 16 21:10 upgrade
    drwxr-xr-x 11 www-data www-data 20480 jan 1 2019 uploads
    -rw-r–r– 1 www-data www-data 4703 jún 30 17:14 wp-cache-config.php

    What chmod or owner/group should be wp-cache-config.php? If I’m correct, the problem is that the wp-cache-phase2.php couldn’t delete the original file during the save?

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    Does the server have permission to write to wp-content? The config file is now written to a temporary file in that directory before renaming to wp-cache-config.php to avoid race issues between competing processes, but I think that now means that wp-content has to be writable.

    wp-content dir:

    drwxr-xr-x 11 ulloi129 ulloi129 4096 aug 16 21:10 wp-content

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    The webserver can’t write to that directory. Can you change it to wxrwxrwxr or 777?

    For a minute, I made that change – only for testing, because it’s unsecure. After that, modify of one setting worked.

    Any advice on this? It’s still not working properly.

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    No, the directory wp-content has to be writeable for the config file to be updated. The directory wp-content/cache/ and uploads directory are writeable too so there’s no point worrying about wp-content if you want to use this plugin.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.