Support » Plugin: WooCommerce » Can’t Save Product Changes

  • After upgrading to WC 3.0.4 from 2.6.14 there were too many broken plugins and issues so we decided to go back to 2.6.14. At first everything seemed to be fine but seemingly all of a sudden I’m unable to save changes to existing products. I’m able to create new products and from my limited testing the new products aren’t affected. This happens with both single and variable products. Also, even though I can create new products, if I copy an existing, non-working, product as a new draft I’m unable to publish the new draft as well. When clicking the Update/Publish button I never get the spinning activity icon and nothing is submitted, as if I never clicked the button. I’ve disabled all plugins except WC and also tried all of the default themes (Twenty Fifteen, Twenty Sixteen, and Twenty Seventeen) with no change. Any ideas would be greatly appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have the same problem! Why you guys released the updates without comprehensive testings? At wordpress I can see updates are saved, but as a customer the existing products were not changed!

    I have a work around to this issue. After a lot of time trying to diagnose this issue I found the following errors in the JS console in Chrome:

    An invalid form control with name='_download_limit' is not focusable.
    An invalid form control with name='_download_expiry' is not focusable.

    After searching the source I found the following form fields:

    <p class="form-field _download_limit_field "><label for="_download_limit">Download limit</label><input type="number" class="short" style="" name="_download_limit" id="_download_limit" value="-1" placeholder="Unlimited" step="1" min="0" /> <span class="description">Leave blank for unlimited re-downloads.</span></p><p class="form-field _download_expiry_field "><label for="_download_expiry">Download expiry</label><input type="number" class="short" style="" name="_download_expiry" id="_download_expiry" value="-1" placeholder="Never" step="1" min="0" /> <span class="description">Enter the number of days before a download link expires, or leave blank.</span></p>

    Searching for the error lead to this answer on stackoverflow. After editing /wp-admin/edit-form-advanced.php line 500 from
    <form name="post" action="post.php" method="post" id="post"<?php
    to
    <form novalidate name="post" action="post.php" method="post" id="post"<?php
    seems to have resolved the issue. I’m still not entirely sure why this is needed or how to fix it without overwriting the core file so any suggestions are welcome. Also, if having novalidate can lead to issues please let me know but for now it’s working.

    I hate to bump posts but I’d still like to know if there are any issues related to this workaround or how to properly resolve it. If this is in the wrong section I apologize and would appreciate it if a moderator could move it.

    bestrafung83 I am so happy you shared a workaround as it was driving me mad for days now…

    marpstar

    (@marpstar)

    I have a solution. Somehow, one of my products got set with a Download Limit and Download Expiry of -1. My product was not even downloadable, but these values were still incorrect. To fix, check the “Downloadable” checkbox for your product and if you see values in the text fields for Download Limit and Download Expiry, clear them out and you’ll be able to save.

    I would not advise anyone to follow advice above, as the wp-admin folder could be changed with future WP updates.

    @marpstar you saved my ass. Thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.