Support » Fixing WordPress » Can’t save posts! Only titles get published…

  • I just set up wordpress and everything seemed pretty easy until I realized I can’t save or publish any of my posts. All I can do is save and publsih titles. Whether I hit, “save and continue editing”, “save” or “publish” I get the same pop-up window that reads:

    “Are you sure you want to navigate away from this page? The changes you made will be lost if you navigate away from this page. Press OK to continue or cancel to stay on the current page.”

    Am I doing something wrong here?

Viewing 9 replies - 16 through 24 (of 24 total)
  • I’m not sure I understand.. my previous post is is a permanent resolution and does not require knowledge of JS.

    When you uploaded the WordPress files to your host, you either uploaded the files via ASCII or BINARY. In your FTP client’s settings, there is an option to set either one of the above or AUTO. The “AUTO” setting will try to automatically decide which method of transfer you would like (ie. *.gif sent as BINARY and *.txt sent as ASCII).

    In this case, my FTP client was set to AUTO and transferred all *.js via BINARY. I simply changed a setting in my FTP client to send all *.js as ASCII instead of BINARY. I reuploaded all files and subdirectories in [../wp-includes/js/] and things work fine.

    Does that make sense?

    yeah…i’ll try that. the other day i was on another computer and uploading thru windows explorer. I have WiseFTP , though, and I’ll see if your solution works.

    thank you.

    it didn’t work. uploaded everything again, JS files in ASCII. Still, I can’t post using the rich editor.

    and just a sidenote, i didn’t see your post about that before the “I don’t know JS thing.” I was just saying that I would look for conflicts there if I was more knowledgeable.

    Sorry to hear that. I’m curious, did you upload all files/directories under [../wp-includes/js/] or just the *.js files only? I ask because I remember the hierarchy being rather large and if you manually went through all directories, perhaps ya just missed one. There are so many JS files in:

    [./../js/tinymce/]
    [./../js/tinymce/autosave]
    [./../js/tinymce/wordpress]
    ..etc

    I only say that because we had the exact same symptoms and I was able to fix mine once I read your posts about disabling the visual editor, which enabled me to focus my troubleshooting. Before that information, I was pulling my hair out with that error, heh.

    tjconroy

    (@tjconroy)

    Your post regarding turning off the visual effects editor worked for me. Thanks you.

    I’m having the same problem as many other people, apparently.

    I tried re-uploading the entire JS folder in ASCII and it didn’t work. Disabling the rich text editor works, but I don’t want to hassle with HTML to make a post.

    What’s really weird is that everything worked fine up until a few weeks ago (and I didn’t make any changes to screw with anything). I just recently installed 2.3.1 and it still didn’t fix the issue.

    Also, what really gets me, is my admin account and any new accounts I create can make posts with titles but no content, however, an old account I made for a co-worker on the Author level can use the rich text editor and make posts with titles and content without a problem. What the heck is with that?

    Any other possible fixes to this? I can use HTML for the time being, but this SHOULD be working.

    Cheers

    wow. and this thread just died out two months ago? was there any resolution that involved keeping the visual editor?

    I just set this up for the first time today and ran into the same problem. I don’t care that much about the visual editor, but when I was trying to make the post and switch it over to “code” ( i don’t mind writing html) it would not let me switch, staying in the visual editor instead.

    any new news about this? I just posted a new thread before I found this one.

    What happens if you turn it off for good (Users > Your profile)?
    Turning off and switching between visual/code is NOT the same thing…

    I found that I had missed uploading a few plugin items so I fixed that. Now I can switch between editors, but only the code editor actually saves and publishes my posts. The visual editor still makes it all disappear.

    And before I found the missing files, turning off the visual editor at users>your profile did work to get the code editor working.

    is there a fix for this, or something we just work around?

Viewing 9 replies - 16 through 24 (of 24 total)
  • The topic ‘Can’t save posts! Only titles get published…’ is closed to new replies.