Support » Plugins » Can’t save plugin options – “You do not have sufficient permissions to…”

  • Howdy,

    I’m the author of a couple of wordpress plugins (Miniposts and Time Release).

    After upgrading to WP 2.8.6, some of my users have recently started reporting that when they try to save the plugins’ option page, they get an error saying:

    You do not have sufficient permissions to access this page

    I’m unable to reproduce that error. Can someone suggest what is going on, and why it would occur on their blogs, but not mine? They are running WP 2.8.6 (as am I), and I’ve tested on pristine WP installations, and installations upgraded from previous versions.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I got the same error. WP 2.8.6 and when trying to update the time release settings I get the same error message.

    Can it be the language files? I´m using swedish language files on my blog http://www.spinell.se.

    Another note: At the plugin page in wp, you are linking Time release to http://www.piepalace.ca/blog/projects/timerelease/ (which gives a 404) and not to http://wordpress.org/extend/plugins/time-release/

    Or can it be something with the way the plugin is installed?

    I used the plugin installation feature in wp – ie I didnt download, unzip, upload.

    Also – it wont show me the images of the “pill”
    This is the directory it is linked to/installed in:
    /wp-content/plugins/timerelease/ui/pill_header.png

    Tried changing the file permissions – no difference, still the same error.

    Hey mrhandley,

    Thanks for reporting that stuff. It looks like WordPress is controlling the permissions on the files that aren’t named ‘timerelease.php’. I’ve created a new version of the plugin (1.0.3).

    Please install it and let me know if you can update the settings.

    e

    – Installed TimeRelease 1.0.3 on a WP blog thats version prior to 2.8.6: Works!
    – Installed TimeRelease 1.0.3 on a WP blog thats version 2.8.6: Works!
    – Upgraded to timerelease 1.0.3 on a 2.8.6 blog. Didn´t work. Had to remove it, and then reinstall it to get it working.

    So you got the permissions working now – great job!

    Am I the only one with image loading problems? The “pill” isn´t showing on any of the WP installations I´ve tried. Or should it be a separate support thread?

    Ugh. That should be a separate thread.

    Thanks for all your help.

    e

    Ok, did that. New support thread: http://wordpress.org/support/topic/339437?replies=1

    Thanks again for a great plugin – works great now (except the pic though)

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can’t save plugin options – “You do not have sufficient permissions to…”’ is closed to new replies.