Support » Fixing WordPress » Can’t Save Page

  • I’m working on a standard WP page (no “posts” on this site, so I don’t know whether they might behave differently). As I edit, I need to save the changes.

    The problem is that the “update” button does not always function, sometimes for hours at a time. Yesterday, the problem was solved by switching from Firefox to Chrome; today, it is not. As recommended in the “Read This First” post, I have cleared the cache in both browsers.

    The changes I made yesterday are correct in the front-end view and obsolete in the “edit page” interface. This is true even when I click the “Edit Page” button in the wpadminbar.

    So I copied the content from the front-end view to the edit view and re-tweaked the format settings. But I can’t save the changes!!!

    Is this a WP problem? A host (Bluehost) problem? Or what? What can I do to fix it???

    P.S. In the process of troubleshooting another problem, I temporarily disabled all plugins. This action did not affect the quirk described above.

    Many thanks for your advice, Anna

Viewing 10 replies - 1 through 10 (of 10 total)
  • Apologies–I forgot to provide a link to the page in progress:

    Dauchy & Co.

    Thanks again, Anna

    P.S. The same thing is still happening…

    WordPress 4.6.1
    Easy Digital Downloads 2.2.6
    Suffusion 4.4.5 Child Theme

    P.P.S. I tried this workaround: Copy the code view to a text file, trash the page, then create a new one from the text file.

    The trash option is also intermittently disabled (at the same times as update button?), so this idea didn’t work.

    The only thing that does work is: Close the page, reopen it, paste the text file, get back to work until it happens again; lather, rinse and repeat.

    BTW a related forums site (WP 4.4.5, bbPress 2.5) seems to work okay.

    Eeeeeek! This problem is getting on my nerves… Can you figure out what causes it—WP? Host? ISP?

    Please help if you can—with profound gratitude, Anna

    Latest [time- and labor-intensive] workaround for saving current edits. This method still seriously interrupts my research train of thought:

    View published page.
    Edit it in Visual Mode by opening “edit page” in a new [Firefox] tab.
    Switch to Text view.
    Copy HTML text.
    Close page.
    View [still open] published page again.
    Click “edit page” by right-clicking “open in new tab.”
    Paste HTML text into text view.

    At this point, the “update” option is always active (for awhile).
    Save current edits by clicking “update.”
    Lather, rinse and repeat…

    What is wrong? So many other pages at the same and a related site seem to work right, so I’m stumped!

    P.S. As reported above: In the process of troubleshooting another problem, I temporarily disabled all plugins. This action did not affect the quirk described here.

    Latest workaround:

    1) Edit text and images as desired.
    2) Copy HTML per “text view.”
    3) Refresh page.
    4) Click “Leave Page” when prompted.
    5) Wait for obsolete page to reload.
    6) Over-write “text view” with pasted HTML.
    7) Update (so far, this option is always available for awhile).
    8) Lather, rinse and repeat…

    Can anyone solve this mystery?

    Thanks again, Anna

    Somehow(?) as suddenly as it began, this problem has apparently fixed itself. For the past few days, the “update” option is working as it should. Stranger Things have happened, huh? Go figure…

    In case anyone tried to help me during this crazy time, thanks!

    Anna

    I finally found a *solution* to this problem, which I suspect was caused by too many saved revisions (hundreds!):

    1) Copy everything from the text view.
    2) Create a new page.
    3) Paste copied text into the text view of the new page.
    4) Save with the default title and slug.
    5) View the front-end display.
    6) Assuming it’s okay, delete the first page and empty the trash.
    7) Rename the new page and slug to the original ones (so search engine and your own links to it will still work!).

    To prevent future problems of this nature, install two plugins that perform these tasks:

    a) Delete all existing revisions.
    b) Limit the number of revisions supported in the future (three is generally recommended).

    You may be amazed by how much faster your site will behave!

    Hope this helps someone, Anna

    I have that same problem, but I am working with page builder
    so I cannot get the text view for the whole page, but only widget by widget
    does anybody fixed this issue?

    Hi @zimmermannc,

    I am suffering from the same that WP does not save my edits. It really bumms me out as it have been already a week. Did you find somehting to fix it or work around this annoying error?

    Hope hearing from you

    yes I found the fix:
    If you are using Page Builder,
    all site origin editor widgets that you have created or modified must be replaced by the black studio visual editor and then it works
    (you must install the black studio widget)
    add a black studio visual editor widget and just copy the html content of the site origin editor widgets into html the black studio visual editor
    and delete the origin editor widget

    From Type historian’s advice, I have installed and activated the two plugins
    1) Black Studio TinyMCE Widget
    2) Optimize Database after Deleting Revisions
    Updated again but still no luck.
    The grey banner on the top of the page still appears.
    Please advise how to save and get rid of the “edit” mode grey banner at the top of the page.
    Sample of issue: http://www.expertrep.co.za/sales-force-effectiveness/

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can’t Save Page’ is closed to new replies.