Support » Fixing WordPress » Can’t save page edits

  • Well it all worked fine in 2.3, but 2.5 and 2.5.1 give an unusual response.

    If I create a page and then publish it it appears fine. If I try and edit it then the changes are not saved. Once I push the save button then I end up at my home page with none of the changes saved. I have reinstalled WordPress and am getting a bit frustrated with it, as far as I can tell it’s been going on for at least a week and I’m not the only one.

    Any suggestions?

Viewing 10 replies - 1 through 10 (of 10 total)
  • I had similar problems:

    I’d changed my site’s url, restored the database, and then wasn’t able to save / edit pages or posts (it just went to the site homepage with no changes made)

    This .htaccess fix in wp-admin did the trick for me, and it’s working again:

    Similar problems. (1) I use Ecto as a front end on my Mac. Suddenly I coudn’t upload images. The error messages asks if the access point is correct. Since the text uploads just fine, it must be.

    (2) I started editing the text in WP, adding the images there. Cool, if inconvenient. Cool for a while, anyhow.

    (3) Then suddenly I could no longer save edit changes. In fact, I couldn’t save even if I had made no changes. Nor could I save if I created an entirely new post.


    I’ve updated to 2.6, and reinstalled 2.6. (The new “restore” function worked nicely, BTW.) But still no joy.

    Where I ought to be sing confirmation that the edit has been save, this is all I get:

    No “action=”. Since I’m getting stonewalled by the same script that zillions of others are using successfully, I have to assume that one of the enabling conditions isn’t being met.

    Question is, which one? And why? I’ve done absolutely no hacking or customizing. It’s default all the way.

    I’m responding to this post because I, too spent massive, unpaid amounts of time trying to find the answer to why my links worked but my Pages resulted in an error page on Save – although the saves were actually working, this was extremely annoying as I had to go back or re-login to continue editing.

    I went through updating Permalinks, tried the “category” and “tag” trick unsucessfully, verified my root .htaccess and index.php files (as my site is in a subdirectory which sometimes creates issues), all to no avail until…

    I finally came across the .htaccess in the wp-admin folder trick mentioned in this article (where someone was getting Ajax errors, which I was not) :

    …and voilà! I can properly save Pages and Posts again.

    The article says :
    If you do not have an .htaccess in your wp-admin/ directory:
    – create a text file on your desktop:
    – put the following inside it:

    <IfModule mod_security.c>
    SecFilterInheritance Off

    – save the file (you could name it htaccess.txt, for example)
    – upload the file to your wp-admin directory
    – rename the uploaded file to .htaccess (with the . in front and remove .txt)

    If you do have an .htaccess in your wp-admin/ directory:
    – edit it by adding the following:

    <IfModule mod_security.c>
    SecFilterInheritance Off

    – be sure to save the new or edited .htaccess

    Note to moderator or other WP folks
    : There are many posts related to this problem after upgrading to 2.6 (on Apache with mod_rewrite, etc.) so it would be great if you could put this info somewhere more easily found as too many people posted “Error after 2.6 upgrade” and other such non-helpful post titles.

    I almost agree with you… however, the method described by you has been referenced in the second post in this topic, even linked to (!), yet the next poster kept posting and rambling instead of following the “easily found” link in the post above his. No comment.

    Next, look at all the “sticky” posts at the top of the forums: they have important information regarding common problems. Do you have an idea how many times a day we have to send people to read those…?



    Just a general heads-up – I was having this same problem in 2.6.5, I followed the tips in the post linked above and nothing was happening, even after flushing my browser cache and restarting (twice) and waiting for 24 hours to see if the problem was in my webhosting server.

    The problem started after I enabled WP Super Cache (the site was rendering really slowly, another problem I haven’t yet resolved entirely) so my first thought (before coming here and trying the .htaccess trick) was that the caching might be interfering – but I disabled and then deactivated it and still no joy.

    Then finally, I just wondered whether the WP Widget Cache plugin might be interfering. That has indeed proved to be the culprit, although I’m not sure why a process aimed at widgets is blocking the editing of pages. I’m off to report it to the author now (after re-enabling Super Cache and Widget Cache to speed up the site again)

    It’s not too horrendous a task to turn off the caching stuff when I want to change a page, but as I’m running the site as a CMS (it’s a comedy guide site) I make more page changes than most in order to update information, so it is a PITA.

    Holy moly, I too am having this problem saving pages in WP 2.7 and it’s been driving me nuts for the last 4 hours or so. I tried the above .htaccess fix but no go. I also tried disabling all plugins, but that didn’t work. I was able to copy and paste a bunch of Lorem ipsum into the page and that saved ok, so I knew it had to be something with the page content.

    It ended up being the word “from” in the content of my page copy. Once I removed that word poof! It saves!!! I can place the word “from” in other pages and I can save a page, so why just this one page? Maybe it’s a combination of certain words or a combination with the page title? Very strange…

    Anyone else have this issue?

    – Jonah

    I just encounted this problem last night. Wierd. No problem with inserting 3rd party html codes but just cannot edit my content.

    I am curious @jonahcoyote, how did you come to discover it is the word ‘from’?

    Thanks tigtog, your solution worked for me – WP-Widget-Cache was the problem! I was getting worried for a minute there. Once got rid of that though, no fuss no muss…

    I was experiencing the same issue of not being able to save edits and posts to WP and the solutions offered here did not work in my situation.

    I found the solution on the post below:

    I contacted my hosting provider about it, they followed the steps outlined in the post above and that fixed my problems.

    I hope this will help others.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can’t save page edits’ is closed to new replies.