WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Can't save or publish new posts

[Resolved] Can't save or publish new posts

  • I am unable to save or publish new posts. I first noticed the problem about 10 days ago. I was hoping when I upgraded to 3.4 yesterday it would fix the problem, but it didn’t.

    I am able to compose new posts but when I click on save or publish, I am kicked out to the “all posts” page.

    I attempted to reinstall 3.4 and I receive the following error: “Forbidden: You don’t have permission to access /wp-admin/update-core.php on this server.”

    URL: http://www.christophersmith-op.com/
    WP Version: 3.4
    All themes and plugins are up to date.

Viewing 15 replies - 1 through 15 (of 16 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    I have the same problem 10 minutes ago, then i change theme to Twenty Eleven.

    No i have error 500 on my dashbord.

    Site i working on Twenty Eleven but i cant change anything.

    esmi

    @esmi

    Forum Moderator

    @elnowako: It is impolite and contrary to forum policy to interrupt another poster’s ongoing thread with a question of your own. Please post your own topic.

    deactivate ADMINER

    that did it for us

    Try doing following steps.

    1. Change the permissions of wp-content to 755
    2. Try replacing wp-admin, wp-includes with the latest one.
    3. Update the database.
    4. Deactivate few plugins if you have any suspect.
    5. Switch back to basic theme like twentyeleven or twentyten.

    I’m kind of a rookie at all this so I guess I’m getting what I deserve (not really since the damn thing should have never crashed in the first place).

    Anyway, I’ve disabled everything – I mean EVERYTHING!!! If you go to my URL now, it looks like something fresh out of the box. None of my content is there. It’s all GONE!! I don’t have any plug-ins installed (it won’t let me install any now) and I’ve changed to a different theme.

    I’ve tried to restore a back-up to bring it back – doesn’t work!
    -That is 541 posts over a two year period I can’t find!!
    I’ve tried to create a new post (the original problem) – still can’t!
    I’ve even tried to say screw it and start a new design without my old content, but none of the changes (colors, title, etc.) I make will save.

    So not only have I lost my old site and all its awesome content, but I can’t even create a new one on the same URL.

    WTF?!?

    Okay, so my latest update.

    First, I was obviously a bit irrational with my last post. I was very frustrated.

    Second, I have restored my site, but the problems that prompted me to originally post still exist. These are some examples:

    1) I can’t save or publish a new blog post. I can compose a new one, but if I click either save or publish, it kicks me out to the list of all my currently published posts. Every thing I typed before I clicked save or publish is lost.

    2) I can’t removed widgets I’ve installed. For example, I had a box advertising the 50th Eucharistic Congress on my front page. It was two weeks ago and I want to delete it. I can delete behind the scenes but if I look at the blog it is still there.

    3) I can’t update plug-ins for the site. For example, right now there is an update available for Jet-Pack because you successfully updated the WP version to 3.4. If I select it and click update, the block becomes unchecked and I get an error at the top that says, “Please select one or more plugins to update.” I can keep doing that over and over again.

    These are just three examples. The bottom line is, I don’t have any behind the scenes control of my website. While I may be able to do certain things (e.g. write a new post or delete a widget), the changes don’t take effect, it’s like they changes are not “saving”.

    These are the actions I have taken so far based on the advice I have seen in the forums (none of these have fixed the problems described above):

    1) Updated to WP 3.4 via simple script
    2) Down a fresh copy of WP 3.4 and uploaded files individually via FTP (1600 files)
    3) Disabled all plug-ins
    4) Tried to create a post while using twenty-eleven theme
    5) Checked to make sure wp-content permissions are 755
    6) Contacted my host (iPage) about the problem. Not surprisingly, they say its a WP problem. Here is a quote from iPage:

    I’ve uploaded a test script at http://www.christophersmith-op.com/test.php and test database connection script at http://www.christophersmith-op.com/testdb.php and both are working fine . Hence, there’s no server side issues.

    I’ve searched the forums and found that I’m not the first person to have the problem:
    This one, from three years ago, describes my exact problem. This one also sounds a lot like my problem.

    The “fixes” are all about the same: change theme, disable plug-ins, update WP. I’ve done all that.

    Now what?

    esmi

    @esmi

    Forum Moderator

    Have you tried:

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    Seriously Esmi?!?

    Your reply was to cut and paste what you sent me two days ago?

    Did you read what I last posted? I know it was long, but that is because it was full of detail!!

    To answer your question simply, with as few words as possible – YES, I tried all the things you recommended. I tried them the last time you recommended them.

    Now what?

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    crsmith89? Take a deep breath and realize we’re trying to help up you on our own time as unpaid volunteers. We’re not the ones with a problem and venting isn’t going to help any of us assist you.

    Switch the theme to Twenty Eleven, deactivate all of your plugins not in the dashboard but by moving the plugins directory out of wp-content. Don’t delete the plugins directory, just move it so WordPress can’t find it.

    Do that and leave it as is.

    Now clear your cache on your browser, re-log in, and visit the post editor. Try to create and publish a post.

    That may fail, but your webserver has logs for when any requests come in and when errors are generated. What do those logs say for the requests coming into your server for that time?

    If the logs are more than 10 lines (and they probably will be) create a pastebin.com paste and share that link here.

    Seems your user lacks the proper privileges. Either:

    1) Create a new administrator user, if possible, and try to login to that account. Delete the user and transfer all posts to the new user. Or try:

    2a) Through PhpMyadmin or similar, inspect wp_usermeta for your user_id and locate meta_key wp_capabilities (where wp_ should be your actual table_prefix, which might not be wp_). Set this to a:1:{s:13:"administrator";s:1:"1";}.

    2b) Then inspect wp_options and ensure the option wp_user_roles is present and contains s:13:"administrator" near the start of the string. Again all occurrences of wp_ is your actual $table_prefix as set in wp-config.php.

    Jan…thank you for talking me down off the ledge. I apologize for my behavior, especially to Esmi

    I followed the directions you provided: switched to 2011, moved plug-ins folder, logged out, cleared cahce, logged in, created a test post, attempted to publish it and, as you guessed, it failed.

    I went to the logs but I didn’t see anything about the failed publishing attempt. I saw my access to the site was recorded, but I tried three times to publish an entry. Here is what I saw. If you wanted me to access a different log, like via phpMYadmin, then I will need some fairly detailed instructions since I have never messed with that stuff before.

    Knut…I attempted to create a new admin user, but I was unable. As for your other recommendations, as I told Jan, I don’t have any experience interfacing with my database with phpMYadmin, so I will need some help navigating that.

    Thank you both for your help.

    The solution to my problem was to reset the settings in my php.ini file in wp-admin. I had modified to allow for larger media uploads but apparently I had set it too high. Amazing how such a little thing, changing one setting, can cripple your site.

    I can’t get my mouse to click on a new post in order to type anything on it. Plus the site grounds around and around like it’s forever trying to load. This has worsened over the past two months and is hopeless now. ??? My other wordpress site is just fine.

    @bethtrissel: This is a resolved thread. Start a new thread for your question. Give more details, like version, tried with all plugins deactivated and using the default theme.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Can't save or publish new posts’ is closed to new replies.
Skip to toolbar