Support » Fixing WordPress » Can't save new items in menu management after moving WordPress

  • I’ve been looking for answer to this for hours, but I can’t seem to find any documentation.

    I started building my WordPress site locally using XAMPP Lite. Once it was close to complete, I moved it to a Windows Server running Apache, PHP and MySQL. HOWEVER, since the move, I can’t seem to save changes to my menus using the new menu management feature. It worked fine while I was working on the site on XAMPP … now, each time I go to add a page, it successfully adds it to the list, but when I click the “Save” button, it reverts back to the old version.

    Interestingly enough, if I REMOVE an item from a menu and click save, it saves the changes! I can create new menus, but adding pages to them is a no-go also.

    I’ve tried deactivating all my plugins and reinstalling WordPress, but I still had the exact same problem. I’m guessing there’s some issue with the write permissions (I had to enable mod_rewrite right after the move because my permalinks broke) but for now, I’m at a loss. Can someone please help?

    Potentially important information:
    PHP Version 5.3.0
    System: Windows NT SRV-HTIMES-WEB 5.2 build 3790 (Windows Server 2003 Standard Edition Service Pack 2) i586
    Apache Version 2.2.11
    Suhosin not installed

Viewing 2 replies - 1 through 2 (of 2 total)
  • Sorry to bump, but did you ever manage to fix this? I’m having the same issue for an editor role in of my installations – if you’re logged in as an editor, you’re unable to successfully add menu items – they’ve vanished whnen you click ‘save’.

    I’ve run across this, I am trying to create a link in the menu (I also tried a link in the blogroll) and it “saves” but the link actually never stayed in the menu….and a new link in the blogroll IS NOT created.

    I’m using WordPress 3.1.2

    PHP information for
    max_execution_time: 60
    max_input_time: 60
    file_uploads: 1
    upload_max_filesize: 10M
    post_max_size: 10M
    safe_mode: 0
    allow_url_fopen: 1
    Other information:
    PHP Server API: apache2handler
    WordPress Version: 3.1.2
    WordPress Blog URI:
    WordPress Installation URI:
    WordPress Theme: /wp-content/themes/nublu
    WordPress Permalink Structure: /%postname%.html
    WordPress wp-content directory is writable
    WordPress does not use Gzip Compression
    WP-Cache is not running on this installation of WordPress
    GD library is installed
    PHP Version: 5.2.17
    MySQL Version: 5.0.77
    Browser used: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20110319 Firefox/3.6.16

    any help???

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can't save new items in menu management after moving WordPress’ is closed to new replies.