Support » Fixing WordPress » Can’t save menu – “The link you followed has expired”

  • Resolved OsakaWebbie

    (@osakawebbie)


    I had been having intermittent occurrences of this error while trying to save changes in various parts of the admin interface, but now I’ve found a location where it’s happening consistently. When I click “Save Menu” on /wp-admin/nav-menus.php, I am greeted with: “The link you followed has expired.” I tried logging out and logging back in, going straight to Appearance->Menus, and then clicking “Save Menu” with no change to the menu at all – I still get the error. Searching the web, the only mention I could find of this error relates to uploading a file that exceeds the maximum upload size setting, but I’m not uploading anything.

    The Network tab in dev tools of Firefox reveals that WP is sending a 403 error on the attempt to submit the form, but I don’t know how to investigate any deeper than that.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator t-p

    (@t-p)

    No, that article only talks about the upload size limit problem (I already read that page when I first saw this error on another page, and again yesterday when the error persisted). As I said, I’m not uploading anything – I’m just saving settings.

    Moderator t-p

    (@t-p)

    To rule out any plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    OsakaWebbie

    (@osakawebbie)

    I had already checked the most likely suspects (plugins I could imagine having any connection to the admin actions involved), but at your suggestion, I checked them all, and it turns out that a seemingly unrelated little plugin called “Custom Post Types Block” was the culprit – even with only that plugin activated (even though that’s silly when CPT UI is not active so I had no CPTs) and a default theme, it threw the error. I’ll notify the plugin author. Sorry to have bothered you – I should have checked everything first.

    • This reply was modified 1 week ago by OsakaWebbie. Reason: mark as resolved
    OsakaWebbie

    (@osakawebbie)

    Hmm, it didn’t mark as resolved as an edit to my last comment – let me try again with a fresh comment.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.