Support » Fixing WordPress » Can’t save draft or preview post

Viewing 15 replies - 1 through 15 (of 15 total)
  • Do you have the headspace2 plugin installed? This caused me a little trouble right after upgrading.

    One thing to do is to try upgrading all of your plugins. If this does not solve the problem, what you need to do is turn off a plugin and try to post. Then turn off the next one…so on and so forth.

    I have some detailed information about this here: Upgrade Woes

    No, I don’t have that plugin. I only have a few plugins, and all were already upgraded. I deactivated all of them and still got the same problem. (I tried your link too and got a 404, by the way.)

    I made a mistake last night when I posted the link, it is working now. My apologies!

    I do not have preview ability on your blog, so that link you sent will not work for me.

    The only thing I would make sure during the steps above, is to disable all the plugins then go back to your post page as a brand new request. If you are on Windows once the page is loaded click Ctrl+F5, if on Mac click Apple+Shift+R or Apple+R to make sure your cache is cleared. Then try again.

    However, I am wondering if you have access to your error logs for your server? I bet that there is some fantastic error sitting in there from when you were saving the posts.

    I did disable all plugins. And just to be sure, I renamed the plugins folder and created a new, empty plugins folder. Problem persists. Spent a couple hours today on this problem, got nowhere.

    I’ve reinstalled wordpress 3.0, and downloaded it separately and re-uploaded the wp-includes folder, which someone else suggested. I also switched to the default theme temporarily to remove that as a factor. All along I’ve been clearing the cache and trying again. I’d consider downgrading back to 2.x, but it’s been a long time since I backed up my sql database, I’ve been backing up the blog all along but didn’t realize I needed to backup that database too, so I’m hesitant to revert too far back.

    I haven’t checked the error logs, where would I find them?

    One other thing I’ve noticed since upgrading to 3.0 which may or may not be related — the updates section is notifying me that the theme “Pool” has an update available, and tells me I have version 1.0.7 installed which can be updated, but I’m not using that theme. Weird, but may not be relevant.

    Thanks for your help so far. Btw, I’m still getting a 404 message accessing your link above.

    Ok, well let’s try this again… Upgrade Woes (new link). The basic information there was to deactivate the plugins one by one.

    I think that something is going on here with your JavaScript. The one thing that I can suggest to you is to first: try another browser before you turn anything back on. See if it works or not, this would mean it’s still a cache issue. Then, if it still does not work I would suggest contacting me privately and we can discuss other possibilities for how to debug this mystery.

    Good thought. I tried 2 other browsers, as well as an entirely different computer, and the results are identical. In case it was a java issue, I updated the version of java (oddly, it hadn’t been updated for 6 months even though it’s scheduled to update each month). But that didn’t solve it either.

    Also, interestingly, I can successfully preview existing posts and existing drafts, and the pages they point to have different formats than the pages pointed to when I try to preview a new post.

    I get this kind of url when I preview an existing post or draft:

    and this when I try to preview a new post:

    It’s this last kind of url that leads to a page saying “comments are closed” rather than a preview of a new post. Deleting the part after the word “true” does not fix it, and I don’t know what creates this extra text.

    The preview_nonce is a once time use only key that is for allowing you to see the post before it is actually saved, this is

    I am very curious that it is not letting you save drafts at all, this really feels like something is wrong with the saving functionality of your site specifically.

    Are you able to publish new posts at all?

    Being able to jump into the site and see the issue would be awesome as I have tools that would help debug the issue. I am sorry I am not much more help than this.

    I am VERY interested in this issue though, so I would really like to hear about any more information that you find.

    Well I found a few more details but still no solution.

    I tried creating a new post and then publishing it, rather than hitting preview or save draft. Publishing does work. This is a workaround, as I can edit the published post further and then republish it, and prevent it from being mailed to subscribers before it’s polished. Not a great solution though. (After I finished an article today, I pasted it in to a new post and hit publish, so that it would be mailed to subscribers with the subscribe2 plugin (reactivated since it didn’t seem that any of the plugins were causing the problem) — this did not work, inexplicably, but I can’t say that this is related to the main problem).

    And, strangely, I noticed one test draft I created yesterday appeared in my list of drafts today. I created multiple test drafts yesterday as I was troubleshooting, and hadn’t noticed this one appear as a draft, but there it was today. Tried to save a new draft to see if the functionality had returned and, no dice.

    I am very confused by this issue. I am unsure if I would be able to help you any further without seeing the issue first hand using some debugging tools to see if I can catch an error while it is happening.

    Strange I replied to this earlier, didn’t get posted. Anyway, I gave up and downgraded to wordpress 2.9.2. Can’t waste anymore time on the problem. I’m going to hold out in future on upgrading until the new versions aren’t new anymore. Thanks for your suggestions though.

    If you come up with a solution I’d like to know. My problem is identical since upgrading to 3.0.

    @ryssmiles I would definitely check your plugins, try disabling them one at a time and see if the problem goes away. If you find out which plugin it is that is causing the problem, please update the thread here.

    @wprelief – Thanks. I disabled all my plugins and it didn’t help. (I only have two anyway) I also updated to a new WP recommended theme since mine we old, but that didn’t help either. Still looking for a solution if anyone comes up with one.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Can’t save draft or preview post’ is closed to new replies.