Toolset Types
[resolved] Can't save custom post type (12 posts)

  1. Jon Schroeder
    Posted 3 years ago #

    I have tested this on three different hosts, using a number of different versions of both Types and WordPress, and I believe I've narrowed it down to my host (Firehost) setup, which they recently changed a bit.

    Here are the modules they added (I believe) to Apache:


    My issue is this: when I attempt to either add or edit a custom post type, I get to the point of pushing "Save Custom Post Type" ... and then I see a white screen, with a url similar to the following (stays the same as before I click the button, but displays a blank white page):


    It should be displaying something like this:


    Has anyone had an issue like this before, or know what might be happening? I don't believe that the issue is within Types, WordPress, or a theme or plugin. I've tested this on more than 10 sites, and every site hosted on Firehost does exactly the same thing (nothing), and every site on Bluehost or GoDaddy hosting (similar sites with the same base theme and plugins, but varying versions of Types and WordPress, going back to just the last version of each), creates the post type correctly.

    Please help! I'm in the middle of a project that has been shot to hell because I tried deleting and re-adding a post type before I was aware of the extent of the problem.


  2. Jon Schroeder
    Posted 3 years ago #

    I've replicated this issue on a clean install of WordPress with just the Types plugin activated. I still believe my server is the issue, but would appreciate any help anyone could provide.

  3. thawkins75
    Posted 3 years ago #

    I don't know if it is the same issue you're describing, but I'm getting a 'HTTP Error 500 (Internal Server Error)' when trying to save a new custom post type. Latest version of both WordPress and Types plugin.

  4. Jon Schroeder
    Posted 3 years ago #

    Could be. I ended up rolling back my entire server over it, but it's working again now.

  5. Jon Schroeder
    Posted 3 years ago #

    Update: the rollback worked for some of my sites, but not all. Version 1.0.4 is working normally, but versions and 1.1.3 are still having the same issue.

    Anyone else seeing this?

  6. thawkins75
    Posted 3 years ago #

    I ended up rolling back a version on the plugin (to 1.0.4) as well and it works now.

  7. BradHarrington
    Posted 3 years ago #

    Same thing exactly for me.

    Anyone have any ideas on what is causing this?

  8. faeronsayn
    Posted 3 years ago #

    I'm having a very similar error, when trying to save Custom Post Types, the screen goes white, and the type is not saved.

  9. Jon Schroeder
    Posted 3 years ago #

    Anyone have even a partial solution? I'm considering just hand-coding custom post types going forward, which would be OK, but it means that my existing custom post types aren't particularly editable in the meantime.

  10. Caridad Zapatero Contreras
    Posted 3 years ago #

    Hi Jon,

    I see your post with the issue resolved on the forum:

    can you mark this thread as resolved?

  11. scien
    Posted 3 years ago #

    It was really annoying to have to go check another thread and register an account over there to get the answer. To finish up this thread...

    The solution is to install the mb_string extension and restart apache. In my case
    sudo yum install -y php-mbstring
    sudo /etc/init.d/httpd restart

    Thanks to caridad.z for pointing to the forum with the answer and luoy for the original solution (http://wp-types.com/forums/topic/blank-page-when-adding-new-post-type/page/2/#post-29990)

  12. Amir Helzer
    Plugin Author

    Posted 3 years ago #

    Great. Thank you for taking the time to register in our forum. I'm sure that you realize that a few minutes of your time had helped save our support folks a lot more. They are dealing with dozens of support requests every day and have to run from one issue to the other.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Toolset Types
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic