WordPress.org

Support

Support » How-To and Troubleshooting » Can't Save Custom Menu

Can't Save Custom Menu

  • Hi,

    I am trying to add a custom menu to my site. I go to Appearance > Menus, and then I select my custom menu under the Main Navigation Menu drop down and click save. But the menu doesn’t appear on the site. When I go back to the Menus page, my custom menu is no longer selected in the Main Navigation Menu pull down.

    I am using the Yin & Yang theme and Network Solutions is my host. I have wordpress 3.4. I’ve been reading other support discussions, and the primary suggestion seems to be to deactivate plug-ins. The only active plug-in I had was jetpack, but I tried deactivating it. It didn’t make a difference.

    I would appreciate any guidance! I’m really at a loss. Thank you in advance for your help!

    Laura

Viewing 15 replies - 1 through 15 (of 15 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    Thanks for your help. I tried all three suggestions with no luck. Any other tricks?

    esmi

    @esmi

    Forum Moderator

    No. Can we see your site using the Twenty Eleven theme with all plugins deactivated?

    I’m having the same issues – fresh install of WP 3.4 and using Twenty Eleven theme.

    Ditto here! Tried deactivating all plugins (including moving them out of the plugins folder) and switching to 2011 theme. Also re-uploaded all WP files.

    Other symptoms: php errors (can’t upload (500 error), can’t delete files (time out)), user-specific menu and panel positions aren’t being saved either.

    Also just noticed: I don’t have a publish button! Page attributes are missing too. Yipes!

    http://hrstarsonline.com

    Hosted at HostGator, just migrated the site there (from a lunarpages subdirectory) via BackupBuddy.

    Sounds like it could be permission problems, though I haven’t heard of that causing menu saving issues it’s definitely a symptom of not being able to upload etc

    http://codex.wordpress.org/Changing_File_Permissions

    Unable to customize any menu. Tried using menu option under appearance and making pages “no parent” and making “order” 0 for home page, 1 for second, 2 for third.

    Tried every solution mentioned above. Am now on twenty eleven with all plugins deactivated.

    Home

    I resolved the issue– it turned out that it was a memory issue. I had to get my host, Network Solutions, to allocate more memory to my site. Hope this helps some of you!

    I have the same problem, after i update my WordPress to 4.0 and 4.1, my custom menu is not save.

    I tried to put wordpress in debug mode, but not successful.

    Thanks LucaShapiro – looks like that is indeed the issue – how bizarre.

    I tried allocating 64M and then 128M in my php.ini file but still get the error:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /srv/www/mywebsite/public_html/wp-admin/includes/nav-menu.php on line 675

    Not for me, I have 256M. I can add, but then I can not edit or remove.

    Options

    @options-trading-guy

    I turned off WP-Super cache, refreshed the page, and bada-bing! the edit I was trying to make to the custom menu was there, even though when saving it I had gotten the same 500 internal server error you guys had seen.

    Not sure if that helps anyone here but it worked for me.

    I am somewhat new to this web creating thing. I tried through the appearance then menu on the dash board to save the the menu, it would not upload to the responsive sample that I am experimenting with?
    Any suggestions appreciated.
    With Kind Regards

    Options

    @options-trading-guy

    These custom menus don’t work too well…

    esmi

    @esmi

    Forum Moderator

    As per the Forum Welcome, please post your own topic. Your problem – despite any similarity in symptoms – is likely to be completely different.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Can't Save Custom Menu’ is closed to new replies.