Support » Plugin: Events Manager » Cant save any settings

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    Hi!

    Do you get a blank page, or does the page load again but no settings get saved?

    If the page reloads correctly and this is happening with all other plugins disabled (i.e. hust EM running), and using a default WP theme, I’d probably suggest getting in touch with your hosts.

    Chances are they have a security rule of some sort that’s blocking our data from getting to your server once you submit it.

    If it’s a blank page, then try enabling WP_DEBUG mode and see what error messages appear, alternatively check your PHP error logs.

    altkmv

    (@altkmv)

    Hello!

    I actually see the screen with the settings after trying to save. Just nothing happens.

    I contacted hosting support. They connected to the site, but could not find the problem. Tech support asked to contact the author of the plugin and find out what the problem is. If I tell them which hosting settings should be set, they will change them.

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    The only thing that comes to mind is the max_input_vars PHP ini value. The default is 1000, if the hosts lower that down a lot, then this might be the reason it happens.

    Aside from that, there’s no other reason why our settings wouldn’t be saved from a WP/EM side of things.

    To debug this, you’d want to output the request variables in events-manager/admin/em-options.php inside the em_options_save() function (around line 5)

    print_r($_REQUEST); die();

    Try saving the settings again, there should be a big array of settings, if not, then my previous answer is likely correct, or it’s a max_input_vars issue.

    Hello Marcus,

    I have the same problem. This is a brand new installation and i am using the default wp theme with only the events manager plugin. Whenever I try to save any setting, it keeps throwing a “You don’t have permission to access /wp-admin/edit.php on this server.” error. I have checked all file and folder permissions and its still the default one 644 and 755 respectively.

    cvtbrian

    (@cvtbrian)

    I am having a similar issue with saving settings. I notice it mostly with the “When” to and from dates and the booking cutoff date on the event edit page. If I change the dates and click the Save Draft button, the dates revert to the original. I am not receiving an error messages. Sometimes I am able to get the dates to save after two or three attempts, or the correct dates will display if I save, navigate to a different page, and then back to that event edit page.

    I started noticing this about a week ago, which was around the time that 5.9.2 came out. I see a note in the change log that mentions the addition of an EM_CACHE constant which if defined as false will disable caching. I’m wondering if that has something to do with it. My site is hosted by DreamHost, and they run the Varnish caching plugin on their servers (I can’t disable it). Maybe it is causing a conflict.

    • This reply was modified 2 weeks ago by  cvtbrian.
    altkmv

    (@altkmv)

    I solved this problem by changing max_input_vars to 10,000. This was done by the hosting tech support

    cvtbrian

    (@cvtbrian)

    Thanks altkmv, I will try that and let you know if it works.

    cvtbrian

    (@cvtbrian)

    I changed the setting to 10,000, but it didn’t solve the problem. I really think it’s a caching problem.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    @cvtbrian I would actually bet on MEMcache and not Varnish here. Varnish doesn’t cache anything on wp-admin by design 🙂

    Are you command line friendly? If so, rename object-cache.php to object-cache.off and see if that fixes it.

    I have FTP access to the files, but I can’t find one called object-cache.php. I do see a cache.php in the wp-includes folder. Would that be it?

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.