Support » Fixing WordPress » Can’t Save a Post or Page with Certain Text

  • jp182


    For some odd reason, I cannot save a Post or a Page that contains the following text and I have no idea why:

    4 Kid Cudi – Pursuit of Happiness
    Who doesn’t pursue happiness these days? What is adored of Kid Cudi is how he simplifies the complexities of life through song. His lyrical approach is straight-forward but very effective. His music makes you feel like you can just lay your head back for a moment and let it all go. Intoxicating from first listen, Cudi carefully selects samples and sounds that set the stage for his unique songs. Pursuit of Happiness is no exception. Could be the reason Kid Cudi made an impressive 3 of MILC’s Top 20 of 2009! Cudi comes from a history of music. His late uncle was famed drummer Kalil Madi, best known for his jazz licks on albums like Mongo Santamaria’s, Watermelon Man.

    I’ve tried copying it into Notepad and then copying it into the post. I’ve tried typing it in and both times it wouldn’t save. Sometimes, it will take the first couple of sentences but nothing more.

    Any ideas why that would happen? I’ve tried shutting down all of my plugins and still can’t figure it out.

    What’s weirder is that I have no problems posting anything else.

Viewing 14 replies - 1 through 14 (of 14 total)
  • alism


    You’ve probably got a particular harsh mod_security rule on the server.

    You can try disabling mod_security (although you would be turning off a security feature), although I seem to remember mod_security2 isn’t turnoffable (if that’s a word).

    (add it to your .htaccess)

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Or you may have to speak to your host to get them to tweak the rules.



    Actually, that’s already in my .htaccess file oddly enough.

    I have the same problem, but I narrowed it down to one single word:

    If I use the word “episode” in any of my drafts, it won’t let me save or preview it. Doesn’t get stranger than this.

    So I’m guessing there is one single word in your text which prevents you from being able to save it.

    Does anyone know why this happens though? Last time I ended up just putting it on our Facebook page and linking to it.

    This time, that’s not really an option for me.

    I have no idea why it happens. My “episode” issue suddenly cleared up on its own, and now I can use the word without a problem.

    I am now having the same problem. If I use the word “where” or “into” in the body of any of my posts or pages the page will not save or publish. if i remove the offending word (or words) the page is just fine.

    this is absolutely bizarre.

    I have now had this issue happen to me twice. The first time was on my own site and I was able to reword the problematic text. Now, it is happening on a client’s site and the offending word is part of someone’s title “Executive”.

    Sort of makes you feel crazy. Wish someone had an answer.

    I’m having the same issue with the word “from”. Anyone have an answer yet?

    Moderator James Huff


    Volunteer Moderator 🚀

    Contact your hosting provider and ask them if mod_security is enabled on your server and if their configuration would be preventing the word “from” (or any other word in your suspect post) from being passed to the database via PHP’s POST command.

    I’m having this same issue, but it doesnt seem to be affecting every user. Some users arent able to post certain texts, I have one post that has multiple instances of the word “from” that seems to be preventing posting. If I replace 4 out of the 5 instances of “from” it will post right away. (I narrowed it down to the second instance of “from” would be the point where the post would break, and then started replacing the instances of that word in the rest of the text. Thought it might have something to do with being a reserved SQL keyword or something…) It doesn’t appear to be related to post length, I can post super long Latin text content without any issues.

    However, a coworker is able to post the same content with no problems, as is the support rep at my host. This issue affects me in both IE and Firefox. (In IE I’ll get a “cannot display the webpage” error, in Firefox the page runs for a while then I get a dialogue box asking me to save “post.php” as it were a downloadable file.) It randomly pops up for other users and their posts.

    I’ve increased the PHP memory limit, the pcre.backtrack_limit and pcre.recursion_limit, and turned off mod_security in .htaccess and wp-config.php. The support rep has confirmed they’re not using mod_security or mod_security2, and there’s no reason that this should be happening as far as they can tell. I created a new installation of 3.0.1 and have no plugins enabled and still can’t post.

    Anyone have any other ideas why this might be happening, and only affecting certain users?


    We are having this issue with a client’s site. Some of the pages can be edited just fine. A few, however, are having issues with a specific word on that page. For example, the word “from” about mid-way down the page doesn’t work. If I remove it or change it to other wording, the page saves fine. What’s even stranger is that “from” is elsewhere on the same page and doesn’t cause an issue there, it’s only when it’s in the one place in the content that the page hangs indefinitely and won’t save. I also tested if the word “select” causes an issue, and it doesn’t appear to.

    The site host is Newtek/CrystalTech and the site was working fine until last Friday. That’s around the same time the site was upgraded from WordPress 3.0.1 to 3.0.2, so we’re not sure if that may be causing the issue. We checked with them about the mod_security issue and they said the site needed to be added to their “whitelist”. That has since been done, and yet the problem persists.

    Are there any other suggestions? Is anyone else still experiencing this issue?

    Thank you,

    After much back and forth with the client’s hosting company, we’ve fixed the issue!

    For anyone else who may be having a similar problem, here’s the solution we found. As mentioned in other posts on, this fix is specific to the client’s web host (Newtek):

    Newtek (formerly CrystalTech, had recently updated the firewall security for the client’s account. They did not confirm it involved mod_security specifically (and we tried the many different mod_security suggestions mentioned in the threads linked at the bottom of this message to no avail), but the techies we spoke with seemed familiar with the issue and suggested we have the client’s account/domain “whitelisted”, which their tech people had to submit a ticket to complete. Once it was complete, the issue was fixed.

    Also, please note, we had them whitelist access for “All IPs” instead of only a few specific ones because the client will access their WordPress dashboard from many locations instead of a few known IP addresses.

    For reference, here are other forum threads that helped us narrow in on the issue & ultimate fix. I hope they help you as well!

    My Server Doesn’t like the word From

    Disable mod_security

    Post content with the word select doesn’t save

    Long post won’t save

    WordPress won’t save this sentence-WTF?

    Got solution but little tricky. just open the phpmyadmin on database of related wordpress. then go to table wp_posts click on it. Under this table you need to see column which has post_title for page where you want to save data and page name should be auto save. befor doing this you need to also open that page in admin. then update in database . all content will be save there……



    I am still following this thread because I am continuing to have the problem on both my own blog and on a client’s blog. Both are hosted at NewTek/CrystalTech. Which I thought was interesting because @vicorock specifically mentioned them as his/her host as well.

    I have just submitted a ticket with NewTek to be whitelisted. I’ll report back with my findings. If this doesn’t work I am seriously wondering about changing hosts?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Can’t Save a Post or Page with Certain Text’ is closed to new replies.