Support » Fixing WordPress » Can’t run upgrade.php on 2.3.1 upgrade

  • Resolved wmccnews


    I’m trying to upgrade from version 2.0 something to 2.3.1. I’ve uploaded everything and followed the extended upgrade instructions carefully but can’t get the upgrade.php script to run. Here’s the message I get when I type in my Firefox browser:

    Warning: main(/home/wmccnews/public_html/wp-settings.php) [function.main]: failed to open stream: No such file or directory in /home/wmccnews/public_html/wp-config.php on line 20

    Fatal error: main() [function.require]: Failed opening required ‘/home/wmccnews/public_html/wp-settings.php’ (include_path=’.:/usr/php4/lib/php:/usr/local/php4/lib/php’) in /home/wmccnews/public_html/wp-config.php on line 20

Viewing 10 replies - 1 through 10 (of 10 total)
  • Did you change your wp-config.php file. If so you might want to confirm that it is correctly edited. Also make sure you are uploading files correctly–use ASCII mode (or auto detect mode if using FileZilla).

    Editing Files
    Editing wp-config.php
    Uploading WordPress to a remote host

    Also make sure your wp-settings.php file is present.

    Thanks very much to both of you.

    I had not changed my wp-config.php file (the instructions were forcefully clear not to touch it!).

    But I took kgagne’s advice and looked to see if I had a wp-settings.php file. I did not, because the instructions said to delete all wp-* files except for the wp-config.php file (and some named folders). So I added back in my old wp-settings.php file.

    Upgrade.php still won’t run but I get a different error message this time:

    Fatal error: Call to undefined function: add_filter() in /home/wmccnews/public_html/wp-includes/default-filters.php on line 8

    What say you?

    I’d first consider deleting the WordPress files and reuploading as per Steps 7 and 8 in Upgrading_WordPress_Extended.

    Just finished that. No change. Made sure that FileZilla was in auto detect, too.


    1. Is upgrade.php supposed to generate all those wp-* files I deleted in the root directory? For example, I added back in wp-settings.php per kgagne’s suggestion, but was upgrade.php to have regenerated that? If so, something else is keeping upgrade.php from running (I guess).

    2. I’m using the Minima Plus theme. That wouldn’t prevent the upgrade.php script from running, would it?

    3. Last question: The last error message I got after I added back in wp-settings.php was a “call to undefined function” that pointed to line 8 of my default-filters.php. That line reads:

    add_filter(‘comment_text’, ‘wptexturize’);

    What in the world would I do to that?

    You do a great service. Thanks.

    The upgrade doesn’t generate any files such as wp-settings. Those get uploaded by you (those are the files in the WordPress distribution you downloaded).

    Again revisit Steps 7 and 8 in Upgrading WordPress Extended and also download a fresh copy of WordPress from the Download link at the top of this page.

    Including wp-config-sample.php, WordPress 2.3.1 has 22 files and 3 folders in the folder called wordpress.

    Michael, you hung in there with me. It’s working now.

    I’m not terribly dumb but I feel it. I had not (and I’m embarrassed to admit it) uploaded the individual files under the wordpress directory. Your response that WordPress has 22 individual files made the light bulb click on. You’re correct to keep directing us novices back to the basics.

    I’ve passed along a word of public thanks in my site

    Many thanks.

    Glad you got it resolved. Thanks for the feedback 😉

    Hey guys – thanks a bunch for a great support site. This just solved my upgrade problem too!

    I had the EXACT same problem as above, and I’m still hosed. I’m trying to upload wordpress (to GoDaddy via FTP) in ASCII format now, to see if that makes any difference.

    I reverted to my old version of wordpress (August 2006), but if it’s just an ASCII/binary problem, I will try upgrading to 2.3.2 again.

    Is anyone out there that I can talk to if I need to?



    PS: My website:

    My current error messages:

    Warning: main(/home/content/f/e/n/fengshuistyle/html/wp-settings.php): failed to open stream: No such file or directory in /home/content/f/e/n/fengshuistyle/html/wp-config.php on line 20

    Fatal error: main(): Failed opening required ‘/home/content/f/e/n/fengshuistyle/html/wp-settings.php’ (include_path=’.:/usr/local/lib/php’) in /home/content/f/e/n/fengshuistyle/html/wp-config.php on line 20

    I did revert to the old version of WP (August 2006), and transferred it using ASCII format. Still no luck.

    Also, pardon my naivete, but when I edit my webpages on GoDaddy using WordPress, where do my actual website pages (content) live? Are they partly embedded in wp-content somewhere? I just don’t get how my whole site could be annihilated. I thought that doing a full backup of my html directory on GoDaddy would save me, but so far, it hasn’t.

    Panic is setting in.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can’t run upgrade.php on 2.3.1 upgrade’ is closed to new replies.