Support » Theme: BresponZive » Can't Run Theme – Undefined functions

  • Resolved zenrhe


    I am just migrating a site. And have come across this error when activating the theme.

    Fatal error: Call to undefined function phpget_template_part() in /home/monsterm/public_html/dir/wp-content/themes/bresponzive/bresponzive/admin/widgets/widgets.php on line 1

    If you comment that file out, it carries on complaining about other functions in the Widgets folder. (like twitter and flickr)

    1) I have this working fine on
    But when I copy the theme folder over to the new host, I get the issue. And being such fatal issues, the only way to get access to the site again is to rename the theme folder to quick wordpress into going back to a default.

    2) I used the original theme files I downloaded instead. This did the same.

    3) I spotted a new version, 1.1.0, so I download that and add it to the ftp. Same thing.

    This site is needing to go live by next week, and this theme fail is holding things up.


Viewing 13 replies - 1 through 13 (of 13 total)
  • Hello,
    should know your configuration. Where the concern comes from your site and not the theme.
    PHP version
    Version of MySQl
    plugins installed
    Host Name
    Thank You

    You are WP 3.6.1 ??

    Theme Author RAJA CRN


    I don’t think, this is a theme problem, because get_template_part() is the WordPress Core function. You might have missed the some WordPress core files or something like this. Try to install the WordPress blog in your test server and test the theme.



    I changed my theme and no problems, so it is good theme, sorry

    Theme Author RAJA CRN


    Do you have any problems, noaneo?

    more now that I’ve changed my theme, if I had the same message zenrhe

    I did select WP 3.6.1 when I posted, strange it doesn’t show it.

    All other themes are working fine.

    TSO are the host. I will need to check the php and mysql versions.
    The main difference is the new site is using Multisite.

    I switched to another theme as I had too much work to get done. So if no-one else has this problem, you could close the ticket. As I wont be going back to the theme until I have another project it might be suitable for.

    I disagree with RAJA CRN that it is a WordPress core issue due to the call, when it’s only the theme theme files that have the problem. But it could be something similar.

    I do love the theme, great work, just a shame something has gone wrong for me in this instance. Hope to use it again in the future and maybe this problem

    Theme Author RAJA CRN


    Thanks and We appreciate your feedback. It looks strange to me. Just now, We have tested the theme in WordPress Multisite with 3.6.1 and it works fine, and we have no issues. Anyways, without further details we can’t help you out.

    may be a conflict with plugins, here is the list of my plugins:
    Akismet (2.5.9) BackWPup (3.0.13), Bad Behavior (2.2.14), Broken Link Checker (1.8.3) Change Permalink Helper (0.1), Contact Form 7 (3.5.2), Disqus Comment System (2.74) Forum_wordpress_fr (3.1), jQuery Updater (2.0.3) Shareaholic | share buttons, analytics, related happy (, TinyMCE Advanced (3.5.8), Viper’s Video Quicktags (6.4.5), WordPress SEO (1.4.15), WP-Memory-Usage (1.2.1) WP-PageNavi (2.83) WP-PostViews (1.65) WP Clean Up (1.2.1) WP Lightbox 2 (2.28.4) Wysija Newsletters (2.5.8)

    i installed the bresponzive

    theme and it was not even getting installed on a fresh version of wordpress with no plugins.

    just out of the box it gives the following error:

    Fatal error: Call to undefined function phpget_template_part() in /home/monsterm/public_html/dir/wp-content/themes/bresponzive/bresponzive/admin/widgets/widgets.php on line 1

    it works fine on Local install with WAMP.

    it even shows the same error if you live preview the theme..

    i couldn’t help but notice the error to the function “phpget_template_part()”

    the function is “get_template_part()” and not “phpget_template_part()”

    this makes me wonder if one too many php tags were opened…

    hope this gets solved

    Theme Author RAJA CRN


    Did you upload via FTP? It may be the character encoding problem. Upload via WP Dashboard.

    it’s been almost one year since the theme has not been updated laors WordPress has evolved.
    the demo is in WP3.6

    Thanks RAJA CRN

    i tried a few other ways of uploading the them,
    via FTP—didn’t work

    via upload by admin pannel of webhost—–didnt work

    I tried uploading multiple times but was unsuccessful

    How ever the files that were being uploaded were uploaded OK..i downloaded the uploaded file and checked

    Directly installing from WordPress—-WORKED…!!

    Strange problem this…but finally got it working…

    Thanks a lot..and keep up the good work..cheers…!!!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Can't Run Theme – Undefined functions’ is closed to new replies.