• Resolved Andreas Lippmann

    (@alliansohog)


    Hello Support!

    I tried to install forminator on my live-webside but the webside crashed and i had to remove forminator.
    Next step i installed a fresh wordpress side on my localhost with MAMP. (php8.0.1 and WordPress 6.4.1) Directly after wordpress was installed i installed the Forminator plugin. But after the plugin installation i could not open the forminator plugin. I cant reach the side. I also did a short regarding the installaion: chrome_h2TSjudnaJ.mp4 You please help me to start with to get started with forminator?

    Thanks /Andreas

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @alliansohog

    I hope you’re well today and thank you for contacting us.

    I can’t say for sure, but I rather doubt it’s the very same culprit in both cases.

    With local servers (such as MAMP and similar), especially if it’s a fresh setup, it would usually be a matter of tweaking some resources in server configurations settings but it may also be some sort of slight misconfiguration of the environment.

    On a webserver and if the site is already a working site with non-default theme and other plugins, it may also be a matter of resources but it can as well be, quite likely, some sort of a conflict.

    It would be best at this point to enable WordPress debugging (to a file) on both site’s, then replicate the issue and check debug.log file.

    To enable debugging you simply add following three lines to the “wp-config.php” file of the site:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUGT_LOG', true );

    Make sure they are above the “/* That’s all, stop editing */” line and then

    – replicate the issue on the site
    – look into the “/wp-content” folder on the server and you should see a file called “debug.log” there
    – share that file with us (e.g. upload it to your Google Drive, Dropbox or similar and include direct link to it in response here)

    There is a good chance that the file will then include some additional debugging information that will give us some clue on why this is happening.

    Best regards,
    Adam

    Thread Starter Andreas Lippmann

    (@alliansohog)

    Hi Adam!

    Thank you for your kind responds. I tired hard to get an output to debug.log on my live page without success. The only i could see from the Debug_Display was follow lines:

    Deprecated: strpos(): Passing null to parameter #1 ($haystack) of type string is deprecated in /home/c3971/public_html/wp-includes/functions.php on line 7241

    Deprecated: str_replace(): Passing null to parameter #3 ($subject) of type array|string is deprecated in /home/c3971/public_html/wp-includes/functions.php on line 2187

    Fatal error: Uncaught ValueError: Unknown format specifier “r” in /home/c3971/public_html/wp-content/plugins/forminator/library/fields/consent.php:80 Stack trace: #0 /home/c3971/public_html/wp-content/plugins/forminator/library/fields/consent.php(80): sprintf(‘Ja, jag godk\xC3\xA4n…’, ‘‘, ‘‘) #1 /home/c3971/public_html/wp-content/plugins/forminator/library/abstracts/abstract-class-field.php(138): Forminator_Consent->defaults() #2 /home/c3971/public_html/wp-includes/class-wp-hook.php(324): Forminator_Field->admin_init_field(”) #3 /home/c3971/public_html/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters(NULL, Array) #4 /home/c3971/public_html/wp-includes/plugin.php(517): WP_Hook->do_action(Array) #5 /home/c3971/public_html/wp-admin/admin.php(175): do_action(‘admin_init’) #6 /home/c3971/public_html/wp-admin/index.php(10): require_once(‘/home/c3971/pub…’) #7 {main} thrown in /home/c3971/public_html/wp-content/plugins/forminator/library/fields/consent.php on line 80
    Ett kritiskt fel har uppstått på webbplatsen. Kolla e-posten till webbplatsens administrationsadress för vidare instruktioner.

    WordPress-version 6.4.1
    Aktivt tema: Enfold (version 5.6.6)
    Nuvarande tillägg: Forminator (version 1.28.0)
    PHP-version 8.1.4

    Plugin Support Zafer – WPMU DEV Support

    (@wpmudevsupport15)

    Hi @alliansohog,

    I hope you are doing well today!

    Thank you for the details. We have informed our Forminator team to check the issue further and will update you accordingly.

    Kind regards,
    Zafer

    Plugin Support Zafer – WPMU DEV Support

    (@wpmudevsupport15)

    Hi again @alliansohog,

    The issue seems to be related with the translation. Please let us know which language you are using on the plugin and if you have modified any translations like Swedish and Norwegian because we have checked and could not find anything related to the following and those mentioned translations has not been completed yet.

    /wp-content/plugins/forminator/library/fields/consent.php(80): sprintf(‘Ja, jag godk\xC3\xA4n…

    If this is not the case, Please send an email to wpsupport@incsub.com and we can continue there.

    Subject: ATTN: WPMU DEV support – wp.org

    Please send:
    – Link to your WordPress site
    – Link back to this thread for reference
    – Any other relevant URLs/info

    To ensure we don’t miss your email, please let us know here once you’ve submitted the form and make sure you use “ATTN: WPMU DEV support – wp.org” as the email subject.

    Kind regards,
    Zafer

    Plugin Support Nithin – WPMU DEV Support

    (@wpmudevsupport11)

    Hi @alliansohog,

    I also got an update from our Developer and it seems like the issue might be more related how the following text is translated:

    Yes, I agree with the %1$s privacy policy%2$s and %3$sterms and conditions%4$s.

    We are assuming it was translated to Swedish incorrectly for the above and hence the issue.

    How did you translate the above text? The reference of the translation should be as follows:

    Ja, jag godkänner %1$s integritetspolicyn %2$s och %3$s villkoren %4$s.

    The above text is translated from Google Translate, so please do tweak if needed.

    Could you please try the above suggestion and then check if it works fine?

    If the issue is still the same even after updating the above translation text and by regenerating the MO file then please do follow up with us via email as requested in our previous response.

    https://wordpress.org/support/topic/cant-run-forminator-on-fresh-installation/#post-17204942

    Regards,

    Nithin

    Thread Starter Andreas Lippmann

    (@alliansohog)

    Hello Nithin!

    Thanks for the troubleshooting and hint to translation issue. Indeed my wordpress backend is swedish and i have the need for some plugins to adjust/translate the frontend text to swedish, using the Loco Translate plugin. I did no changes in the Loco translation plugin when it comes to the forminator plugin, cause i could not even run the forminator plugin without crash. So i test to deactivate the Loco Tranlate plugin and had no issue afterwards to install/navigate in the forminator plugin. I guess now that the issue is not on your plugin and will investigate more how i can make the 2 plugins to work.

    Thanks again for your time and help. /Andreas

    Tim W

    (@timwhitlock)

    Author of Loco Translate here.

    As per my FAQ on this very common problem – A badly formatted translation can break your website. See the ValueError section:

    This is undoubtedly the problem as your error log explains – Unknown format specifier "r". Somewhere in the Swedish text will be something like %r or %1$r or similar. In the English where you see %1$s (numbers 1-4) the “s” must remain intact in your translation.

    To see the full string including the erroneous part, you can set zend.exception_string_param_max_len to a higher value (default is 15) which is why your error shows truncated text. This is academic though, because you’re going to have to find and fix it regardless.

    As the offending string has no entry in the community translations, it certainly looks like the translation has been modified by something on your system. The fact the error goes away when you disable my plugin, suggests that it’s held in Loco Translate’s custom file location. However, Loco Translate does not save translations in the background, or in any other way without you pressing “save” in the editor. For this reason, I can’t account for how it got there.

    If the translation is in a custom PO file, it is a simple matter of finding it and editing it. If – as you say – you can’t run Loco Translate without this error, you would have to disable the plugin that is rendering the bad string. (This plugin). Then when fixed, re-enable it. Alternatively, switch your site to English while you fix it. Or even delete the Swedish MO file, which will be regenerated when you save the PO.

    Plugin Support Nithin – WPMU DEV Support

    (@wpmudevsupport11)

    Hi @alliansohog,

    Since we haven’t heard from you for a while and the issue is more specific to how its translated as suggested before. I’ll mark this thread as resolved for now. Please feel free to re-open the thread if you need further assistance.

    Best Regards
    Nithin

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can´t run Forminator on fresh installation’ is closed to new replies.