Support » Installing WordPress » can’t run auto upgrade

  • Resolved vwvr9

    (@vwvr9)


    Guys, need your advice. auto update does not work for me. I can upload a plugin and install it using the plug in page but when I try to Upgrade WordPress I keep getting the error below.

    Downloading update from http://wordpress.org/wordpress-2.7.zip

    Download failed.: name lookup timed out

    Installation Failed

Viewing 14 replies - 1 through 14 (of 14 total)
  • Disaable all Plugins and follow Upgrading WordPress Extended to install the 2.7 upgrade.

    MichaelH,

    I did that twice and I still the get the same error. Also what weird is the I keep getting the update nag screen even after the upgrade.

    Is there a flag in the DB for the WP-ID?

    I don’t think so, it’s in the version.php (in the WP root I believe).

    Thanks Gangleri. Seems like something was cached somewhere. Seems ok now.

    WP 2.7 has a bug that has to do with DNS name resolution. As a workaround, add the following to your local /etc/hosts:

    72.233.56.139 downloads.wordpress.org

    yep, that fixed it.

    Thanks venik4 that really workd πŸ™‚

    Hi there! πŸ™‚

    I got a question: Where exactly do I enter the line of code?! I don’t have a file called hosts…

    Even more strange – since this bug appeared yesterday I am no more able to define a static page as Homepage. When I do this the front end doesn’t show up anymore… any ideas!?

    Thanks,
    AndrΓ©

    Bzzzzzt. Try again.

    Upgrade WordPress
    Downloading update from http://wordpress.org/wordpress-2.7.1.zip
    Download failed.: name lookup timed out
    Installation Failed

    I have the entry in /etc/hosts .. and when I am at a command line I can use wget for the file path shown above.

    I can also successfully update plugins using the auto-update feature with no issues at all. This is quite frustrating. I thought perhaps there was something going on with cURL (which I assume is being used) so I applied an update to it.. same results.

    This appears to be an intermittent problem; I solved it by disabling cURL using the Core Control plugin. Here are the details:

    Download and install this plugin manually: http://wordpress.org/extend/plugins/core-control/ Once you’ve activated it, Load the “Core Control” settings page and activate the “HTTP Module”. Go to the new tab fore the “HTTP Module” and test cURL. You will most likely receive the following error message “An Error has occured: name lookup timed out” Now click the “Disable Transport” link in for cURL. You should now be able install plugins and plugin updates.

    Here is the bug report: http://core.trac.wordpress.org/ticket/9998

    Thanks for the detailed explanation, CarltonBale. Your solution worked for me, too πŸ™‚

    CarltonBale, Thank you! It was a bit trickier, but combined with guesses it worked perfectly. Thank you a million times.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘can’t run auto upgrade’ is closed to new replies.