Support » Plugin: Media Cleaner » Can’t restore, can’t delete, analyze stuck on 0

  • Resolved kathycac

    (@kathycac)


    This is a WP Multisite network. The plugin worked great but suddenly stopped working correctly. I tried updating it to the most recent version and the issue didn’t go away.
    The issue is that it tries to analyze when restoring or deleting files and gets stuck on 0. Nothing has changed on the network as far as plugins or versions of plugins in the last month or two that the plugin has been installed. I see others have reported similar issues. Have you found a solution for this issue?
    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Jordy Meow

    (@tigroumeow)

    Hi,

    The issues mentioned before were probably not the same ones, I have fixed all the issues of the past months in the very latest release.

    Did you check your PHP Error Logs? Do you have something in there? Is there anything displayed in the console in your Chrome Developer Tools when you click on the buttons?

    Here’s what I get in Chrome Developer Tools:

    JQMIGRATE: Migrate is installed, version 1.4.1
    upload.php?page=media-cleaner&s&view=deleted:1 Uncaught SyntaxError: Unexpected token F in JSON at position 0
    at JSON.parse (<anonymous>)
    at Function.n.parseJSON (load-scripts.php:4)
    at Function.a.parseJSON (load-scripts.php:9)
    at Object.success (media-cleaner.js:122)
    at i (load-scripts.php:2)
    at Object.fireWith [as resolveWith] (load-scripts.php:2)
    at y (load-scripts.php:4)
    at XMLHttpRequest.c (load-scripts.php:4)

    Plugin Author Jordy Meow

    (@tigroumeow)

    Hi @kathycac, you should have a look at your PHP Error Logs. The errors are on the server in that case.

    And here is a PHP error:

    PHP Warning: rename(/nas/content/staging/jppss/wp-content/uploads/wpmc-trash/,/nas/content/staging/jppss/wp-content/uploads/): Directory not empty in /nas/content/staging/jppss/wp-content/plugins/media-cleaner/core.php on line 504, referer: http://websitename.com/wp-admin/upload.php?page=media-cleaner&s&view=deleted

    • This reply was modified 1 year, 10 months ago by  kathycac.

    It stopped working after a WordPress version update I think.

    Hi Jordy,

    Do you have any suggestions for me? I can’t permanently delete or restore any of the items in trash. Nothing is working.

    And I am concerned about deleting the media trash folder directly on the server.

    Are the items that have been restored and still listed under “issues” and “ignore” physically removed from the trash folder on the server?

    Thanks,

    Kathy

    Plugin Author Jordy Meow

    (@tigroumeow)

    Hello,

    I am tracking this issue, a few users have it, but most (95%) don’t have it. It’s something particular about those installs but I don’t know what yet. Can you contact me here? -> https://meowapps.com/contact/

    Yes. Which button should I click?

    “Ask for My Help” or “Let’s Start” under support?

    Thanks,

    Kathy

    Plugin Author Jordy Meow

    (@tigroumeow)

    It’s “Let’s start” 🙂

    : )

    OK – I just submitted a help request – it’s a different email than this one – I also added a license key but the pro version is not installed on the website because it wasn’t working on multisite – I would have needed a different license – for 90 sites.

    Sorry to take so long to get back to you on this!

    Thanks,
    Kathy

    Hello
    Any news about that problem ? I have exactly the same on a multisite installation 4.8.3

    Thanks for your reply

    Plugin Author Jordy Meow

    (@tigroumeow)

    It’s not about being multisite. I found the issue, and fixed it, waiting for one user to confirm it works before I push the new update. Should be available in a few hours.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Can’t restore, can’t delete, analyze stuck on 0’ is closed to new replies.