Support » Plugin: Yoast SEO » Can’t reply to comments after Yoast update

  • Resolved winandarreza

    (@winandarreza)


    I’m using Genesis theme and all of the plugins and WordPress version are up to date.

    I’m seeing another person facing the same issue as me:
    https://wordpress.org/support/topic/cant-reply-to-comment-anymore/

    I’ve contacted Genesis and they said that Yoast is incorrectly stripping the ‘replytocom’ parameter.

    I don’t know whose fault is this, but Genesis certainly said that the bug is from Yoast.

    Could you release an update to fix this bug?

    Regards,
    Reza

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support jerparx

    (@jerparx)

    Hello @winandarreza

    We apologize for the inconvenience. It seems that the same issue has been reported in our GH repository which you can view here.

    Can you please confirm if you are on the latest Yoast SEO 11.4? When you perform a conflict check by disabling all other plugins and switching your theme to the default WordPress theme, does the issue persist?

    Yes I’m on the latest Yoast and WordPress version.

    Yes, the issue only appears when Yoast is activated.

    One of my websites uses the old version of Yoast but with the same latest Genesis version, and the comment reply just works fine.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We have Genesis v2.10.1 with Yoast SEO v11.4 and we were able to comment. See image https://pasteboard.co/IjZWiL8.png.

    Can you verify you were able to perform a full and complete conflict check by disabling all other plugins and switching your theme to the default WordPress theme?

    winandarreza

    (@winandarreza)

    I did the conflict check by disabling other plugins and switching to twentynineteen, and here’s what I observed:

    When all plugins are disabled, the comment reply button works just fine, showing a URL like this:
    https://multipotens.com/brain-training-apps/?replytocom=3312#respond

    But when I enable Yoast, the URL of the reply button changed to this:
    https://multipotens.com/brain-training-apps/#comment-3312

    elise.x

    (@elisex-1)

    If you have the Twenty Nineteen theme active, and Yoast’s plugin is the only plugin enabled, do you still have issues with the reply feature?

    I do, but didn’t notice this before I left my comment (so it’s not a Genesis conflict, it’s just Yoast bugging out on its own for me).

    • This reply was modified 3 months ago by  elise.x.
    winandarreza

    (@winandarreza)

    @elisex-1 Yes, as I said above, the issue still persists even with the default theme and only Yoast activated.

    elise.x

    (@elisex-1)

    Thanks for clarifying!

    If I’m correct, I don’t think the URL change from ?replytocom to #comment-x is the issue.

    I’m pretty sure before these past few updates, the URL of the reply button did change to the format x.com/x/#comment-x whenever Yoast was active, but the reply feature would still function properly. Now the URL changes, but the reply feature doesn’t work.

    And I know everybody keeps telling me to add this snippet to my functions.php file to return to ?replytocom:

    add_filter( 'wpseo_remove_reply_to_com', '__return_false' );

    But I also understood that Yoast’s workaround, changing to #comment-x was made in order to improve SEO by removing dupe content through extra pages being created by the ?replytocom feature.

    I don’t want to revert back to ?replytocom, I want the Yoast #comment-x feature to work as it used to so I can reap its possible SEO benefits, but when I mentioned this it wasn’t addressed on the GH repository (though maybe I wasn’t clear enough there), so I assumed unless other people began reporting the issue, my desire for a fix would be ignored.

    Plugin Support Pcosta88

    (@pcosta88)

    @winandarreza

    We were not able to reproduce the issue. We made a post without Yoast active and added a comment. We saw that it was replytocom. See image: https://pasteboard.co/Il3uxjf.jpg

    We then activated Yoast and were able to add a reply to comments and create new comments. See image https://pasteboard.co/Il3uOyE.jpg

    We ask that you please make sure all plugins are updated (Yoast has a new version v11.5), make sure any browser plugins are disabled, and test it in a different browser like FireFox or Chrome.

    If the issue is still happening we expect this to be a bug. We’re actively using the bug tracking on our GitHub repository so your best next step would be to create a new issue for our developers at https://github.com/Yoast/wordpress-seo/issues/new. You will need an account to create a new issue. If this is your first bug report, please check out: https://kb.yoast.com/kb/how-to-write-a-good-bug-report/.

    @pcosta88 @elisex-1

    All plugins and themes are updated to the latest version. All browser plugins are turned off. Even I turned off ads (Ezoic) and cleared Cloudflare cache. I tested using Firefox, Chrome, and Opera.

    Same thing, when Yoast is activated, I can’t reply to any existing comments.

    But you know what? I started turning off some features on Cloudflare, like Autominify, Brotli, and Rocket Loader.

    And finally the bug disappear!

    After thoroughly testing which feature is causing the bug, I can say for me it was the Rocket Loader feature. I think it messes up with the Javascript.

    Yes, I can just turn it off and the bug will disappear, but Rocket Loader really helps my websites to load faster.

    It would be nice if you guys release an update to fix this issue now you know what’s causing the problem.

    Have a nice day,
    Reza

    Can confirm, when the Rocket Loader feature on Cloudflare is disabled, Yoast’s comment system works again for me. Love to know if you guys would be able to release a fix as well.

    (also, thanks @winandarreza for figuring this out!)

    • This reply was modified 2 months, 3 weeks ago by  elise.x.
    Plugin Support devnihil

    (@devnihil)

    @elisex-1 Thanks for confirming that the issue was resolved once the Rocket Loader was disabled on Cloudflare. Now that the cause of the issue is known we would recommend submitting a new bug report at https://github.com/Yoast/wordpress-seo/issues/new. Don’t forget to include the URL to this conversation in your bug report.

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.