Support » How-To and Troubleshooting » Can’t Remove/Edit Widget in WordPress 2.5

Can’t Remove/Edit Widget in WordPress 2.5

  • I’m using the latest version (2.5) and while playing with the text widget, the “edit” button disappeared. Now, I can’t edit nor remove the text widget. Also, how do I revert to default widgets? Any suggestions how I can go about this problem? I will really appreciate your help guys. Thanks in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I was able to fix it. Please ignore my post. I just tried to access admin using explorer instead of firefox. 🙂

    How exactly is that a fix? IMO is should work on both browsers.

    Yes, it should!

    I just had the same problem with a Categories widget that was locked, with no Edit, Change or Remove button on sight. The funny thing was that the original Categories widget was still showing at the Available Widgets list.

    So if you can’t remove (delete / uninstall) a widget from your sidebar, just log in with Internet Explorer and the Edit button will be there for you to use it. Then, of course, logout and return to your lovely Mozilla Firefox.


    Wow. Thanks.

    That totally worked.


    I wonder why?

    How bizarre. Logging in with IE worked for me too! Wish I would have found this fix earlier!!!

    Same problem. Same fix. Very weird. Thanks!

    No fix for linux users then. 🙁

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can’t Remove/Edit Widget in WordPress 2.5’ is closed to new replies.