Support » Plugin: WooCommerce » Can’t remove “This is a demo store for testing purposes…”

  • Resolved suburbanworms

    (@suburbanworms)


    I’ve been working on setting up a simple web store over the past few weeks so I’ve had the “This is a demo store for testing purposes…” banner up to prevent orders/confusion. I’m ready to start taking orders now, but when I go to WooCommerce –> Settings –> General the checkbox to add/remove the banner is gone, yet the banner remains. This all happened yesterday, after the update. This is my first time designing a website, so it could be user error, but I’ve exhausted all other options I can think of to find a solution, so I’m posting here. Help is appreciated!

    Ben

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Mike Jolley

    (@mikejolley)

    Appearance > Customize > WooCommerce. You’ll find the options there.

    Can you add it back to the WooCommerce settings page? I’m ok with it appearing in the new location also, but it was easier to access it before.

    Caleb Burks

    (@icaleb)

    Automattic Happiness Engineer

    This setting is now just one page away from wherever you are on your site. Click “Customize” in the admin top bar, then go to the WooCommerce > Store Notice tab.

    You can view your changes live rather than having to save a backend settings and refresh your frontend to test.

    Having the setting in two places would be silly.

    I have done all I know, and Mike Jolley, even double checked your advise but still the “This is a demo store for testing purposes — no orders shall be fulfilled.” blue banner appears on my site and I can not remove it. Please help!

    I too have this problem. I have unchecked the checkbox from the customize->woo commerce->store notice. I have even removed the notice text from the box, and yet it still appears every time I log out and log back in. This absolutely has to go! I can’t have customers thinking our store doesn’t work. Does anyone have a solution to this? Thanks in advance.

    For reasons unknown, after weeks of this issue, it has just “disappeared”!

    libertytalk

    (@libertytalk)

    I reject the notion that this is somehow more efficient removing it from the WooCommerce settings page where it has been forever to the “Appearance” tab which takes you out of the WooCommerce area and into an appearance menu that no one with any actual professional need ever uses as appearance options are already in theme control panels or hard-coded in a child-theme stylesheet.

    The appearance menu remains for casual users.

    libertytalk

    (@libertytalk)

    Let alone it does not even appear on site when the button is checked.

    Dear WooCommerce Plugin Author: Please learn to appreciate the old adage: If it ain’t broke don’t fix it.

    Worked fine for years where it was… prior to this “upgrade.” Yikes man.

    bathgeek

    (@bathgeek)

    Worse, I can’t even get to “Customize”. https://www.bathgeek.com/wp-admin/customize.php?return=%2Fwp-admin%2Fthemes.php returns a broken link. What the heck?

    • This reply was modified 3 years ago by bathgeek.

    Any news @mikejolley? Simply unchecking the box is not enough. The message is still there making my customers going away. Thanks, Davide

    Did you clear the browser cache?

    I am having this issue. No wordpress caching setup – have had siteground double check I had cleared all caches. Have looked in the database and ensured that both option value and autoload value for woocomerce_demo_store is no.
    This issue is present for last few weeks as site is live.
    Under apperance,customise, woocommerce, store notice is definitely unticked.
    Both woocommerce and wordpress are at latest editions.

    Page help needed with is – https://misscuticle.com/

    • This reply was modified 2 years, 7 months ago by niamhh. Reason: forgot to add link to site where issue is present

    Fixed it by clearing the cache files stored in public_html/wp-content/cache/ – hope this helps someone else as it nearly drove me crazy trying to find the answer ..

    Hi!
    I do not have “Customize” option at “Appearance” tab.
    The only options are “Widgets” and “Menus”.
    How can I resolve this situation?
    TY

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Can’t remove “This is a demo store for testing purposes…”’ is closed to new replies.