Support » Plugin: Simple Event Management – Sugar Calendar (Lite) » Can’t remove permalink prefix

  • I’m unable to remove the ‘events’ prefix from the calendar entries. I’ve attempted to change it via the hook ‘sc_event_rewrite’ but it isn’t working. My understanding is that it overwrites the rewrite post type argument and so setting ‘with_front’ to true (from the plugin default of false) should remove this (my permalink structure has posts showing without a prefix and updating this after changing the hook doesn’t work either). Have I done something wrong with this/misunderstood or is it the plugin? I can, for example, change the ‘slug’ to anything and it’ll change the /events/ properly but I’m wondering if I can straight up remove it.

    Thanks!

    Tom

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author John James Jacoby

    (@johnjamesjacoby)

    When you filter these values directly with code, you need to forcibly refresh the WordPress permalinks in the database for them to take effect.

    The easiest and most reliable way to do this is by visiting Settings > Permalinks and simply saving the settings there.

    Also, if you are using any caching plugins, you will need to flush the entire cache to make sure there are no collisions with Pages.

    (It’s generally not advisable to remove the archive slug for performance reasons, but this filter exists in this spot for advanced use-cases where sites require this kind of flexibility.)

    Give it a try, and hopefully it works as intended for you.

    I tried this before creating the topic. I must’ve been unclear about this.

    Plugin Author mordauk

    (@mordauk)

    @vervetom could you show us the exact code you’re using to make the change?

    just use – if budddpresss
    define ( ‘BP_ENABLE_ROOT_PROFILES’, true );

    after that go to premalinks and use %username%

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.