Support » Plugin: External Links - nofollow, noopener & new window » Can’t remove noreferrer link

  • Resolved vadow

    (@vadow)


    Hello,

    I can’t remove rel=noreferrer” to my links even if the page is excluded and the excluded option are unchecked for noreferrer.

    I also change manualy this attribute to each like but as soon as I save the changes, noreferrer is there again.

    Here are my technical info :
    WP url: https://latavernedesartistes.com
    WP version: 5.3
    PHP version: 7.2.22
    Active Plugins:
    – Akismet Anti-Spam, version: 4.1.3
    – ARVE Advanced Responsive Video Embedder, version: 8.10.20
    – CBX Bookmark, version: 1.4.9
    – Cookie Notice, version: 1.2.48
    – Duplicator, version: 1.3.24
    – Fusion Builder, version: 2.1.2
    – Fusion Core, version: 4.1.2
    – Jetpack by WordPress.com, version: 8.0
    – Like Button Rating ♥ LikeBtn, version: 2.6.23
    – Loco Translate, version: 2.3.1
    – Mailchimp for WooCommerce, version: 2.3
    – Maintenance, version: 3.85
    – Private Messages Add-on for UserPro, version: 4.9.2
    – Really Simple SSL, version: 3.2.6
    – Smush, version: 3.3.2
    – UpdraftPlus – Backup/Restore, version: 1.16.21
    – User Menus, version: 1.2.1
    – UserPro, version: 4.9.35.1
    – W3 Total Cache, version: 0.11.0
    – weForms, version: 1.4.2
    – WooCommerce, version: 3.8.1
    – WooCommerce Admin, version: 0.23.1
    – WooCommerce PayPal Checkout Gateway, version: 1.6.18
    – WooCommerce Services, version: 1.22.2
    – WooCommerce Stripe Gateway, version: 4.3.1
    – Wordfence Security, version: 7.4.2
    – WP External Links, version: 2.40
    – WP Report Post, version: 2.1.2
    – WPS Hide Login, version: 1.5.4.2
    – WP User Frontend, version: 3.1.13
    – Yoast SEO, version: 12.7

    WPEL Settings:
    array(
    ‘wpel-external-link-settings’ => array (
    ‘apply_settings’ => ‘1’,
    ‘target’ => ‘_blank’,
    ‘target_overwrite’ => ‘1’,
    ‘rel_follow’ => ‘nofollow’,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ”,
    ‘rel_external’ => ‘1’,
    ‘rel_sponsored’ => ”,
    ‘rel_ugc’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ‘image’,
    ‘icon_image’ => ’13’,
    ‘icon_dashicon’ => ‘dashicons-menu’,
    ‘icon_fontawesome’ => ‘fa-address-book’,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-internal-link-settings’ => array (
    ‘apply_settings’ => ”,
    ‘target’ => ”,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ”,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ”,
    ‘icon_fontawesome’ => ”,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-excluded-link-settings’ => array (
    ‘apply_settings’ => ‘1’,
    ‘target’ => ‘_blank’,
    ‘target_overwrite’ => ‘1’,
    ‘rel_follow’ => ‘follow’,
    ‘rel_follow_overwrite’ => ‘1’,
    ‘rel_noopener’ => ”,
    ‘rel_noreferrer’ => ”,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ‘dashicons-menu’,
    ‘icon_fontawesome’ => ‘fa-address-book’,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-exceptions-settings’ => array (
    ‘apply_all’ => ”,
    ‘apply_post_content’ => ‘1’,
    ‘apply_comments’ => ‘1’,
    ‘apply_widgets’ => ”,
    ‘skip_post_ids’ => ‘173,12,789,191’,
    ‘ignore_classes’ => ”,
    ‘subdomains_as_internal_links’ => ”,
    ‘include_urls’ => ”,
    ‘exclude_urls’ => ”,
    ‘excludes_as_internal_links’ => ”,
    ‘ignore_script_tags’ => ‘1’,
    ‘ignore_mailto_links’ => ‘1’,
    ),
    ‘wpel-admin-settings’ => array (
    ‘own_admin_menu’ => ‘1’,
    ),
    );

    Hope you can help me

    Thank you

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author WebFactory

    (@webfactory)

    Hi,
    You want to remove noreferrer from links that have it hardcoded in the post?

    vadow

    (@vadow)

    Hi,
    Ok my bad, after I disable the plugin, the issue still occures. It appears that it is a security feature from tinyMCE in the core of WordPress.
    May you remove this topic, I don’t want my technical info to be visible for safety reasons.
    Thank you

    Plugin Author WebFactory

    (@webfactory)

    Hi, unfortunately, I don’t have the access rights to remove a topic, but you can edit your first post and remove any sensitive data.

    If you have a minute, please rate the plugin. It’s what keeps support free. https://wordpress.org/support/plugin/wp-external-links/reviews/#new-post

    Moderator Marius L. J.

    (@clorith)

    Hiya @vadow, I see you reported this topic.

    There’s no sensitive information here that needs removing, as such, no action will be taken from the moderators side.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.