Support » Plugin: Yoast SEO » Can’t remove front page slug (.com/home)

  • Resolved consistentbenny

    (@consistentbenny)


    Hi there!

    I have the small but very annoying problem that my homepage / front page is having a slug defined in the editor. Neither in the editor or through quick edit I can remove the slug, it comes right back when I save. The permalink however is correct and does not show the slug.

    The problem is, that I have set all the other pages to be child pages of my front page, assuming this makes sense from a site structure point of view. So all pages like “About” or my “Contact” page are now set to have my “Home” page as the parent page. The stupid thing is that now all the slugs are not “*.com/about” or “*.com/contact”, but instead are “*.com/home/about” and “*.com/home/contact”.

    I do not know how to fix it. In the WordPress Reading settings I have set the “Home” page as my static front page.

    How do I get rid of this slug???

    Thanks in advance, it is driving me crazy.

    Cheers!

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi Benny. About, Contact etc should not be children of Home. That might fix everything.

    That would fix this problem, but one thing that actually made me realize this issue:

    When optimizing the snippet for the Home page, the preview of the snippet was also showing breadcrumbs instead of just the URL. So the Google snippet was showing “https://consistentme.com > home” instead of just “https://consistentme.com”.

    Before that I thought the slug is normal, but trying to remove this issue I was reading that actually the front page usually just does not have a defined slug and I don’t know why mine has.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    Yoast does not set the slug for the homepage so we are not sure why yours does. We do know Yoast will pull from the permalinks of the page so the breadcrumb will show as: https://consistentme.com > home.

    To resolve the issue we can only say to:

    1. Go to Settings-General and make sure the Site and WordPress address are correct. If you are not sure, your host provider can help with this section

    2. Contact your theme developer for more information as to why the homepage is showing a slug.

    Plugin Support amboutwe

    (@amboutwe)

    This thread has been marked as resolved due to lack of activity.

    You’re always welcome to re-open this topic. Please read this post before opening a new request.

    Thanks for understanding!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.