Support » Plugin: Helpful » Can’t rate an article in chromium-based browsers

  • Resolved antontkachev

    (@antontkachev)


    Hey!

    You’re plugin is great, I really fancy it, thanks 🙂

    Once thing that bugs me atm is that I can’t rate an article in chromium-based browsers: Chrome, Brave, Opera, Safari. I hit the button and nothing happens. Sometimes it works after I click the button many times. But not every time so idk what’s the matter. Couple of my friends confirmed this behavior from their computers. In Firefox it works like a charm.

    Hope you will be able to at least tell me where to dig cause now I’m at a loss and ready to consider trying another plugin. But yours is great so I’d prefer to stick with it. That’s why I decided to reach out to you here first.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Pixelbart

    (@pixelbart)

    Hi @antontkachev

    Unfortunately, this is not a problem of Helpful, but of the caching of your site and security settings of your server. The request that Helpful sends always lands correctly, but is returned with 403. So Forbidden.

    You have to disable the nonces in the settings (Helpful > Setttings > System) of Helpful and see if it works then. Many have this problem, because of the caching. Disabling the nonces makes Helpful more insecure. You have to decide yourself what is more important to you.

    Unfortunately, these are not problems that I can solve from my side.

    Stay healthy and thanks for your feedback!

    PS: I test all browsers except Safari on multiple devices before releasing an update. So Helpful always works under normal circumstances (no caching, default WordPress theme and no other plugins).

    Thread Starter antontkachev

    (@antontkachev)

    Thanks for a swift response!

    I thought that the problem could be at my side. Disabling the nonces makes Helpful insecure in what way? Is there a risk someone will hack my site?

    An alternative solution would be to change settings at the side of my server, right? Can it be done securely?

    Upd: I guess the culprit could be Autoptimize. I read that one can exclude particular scripts in settings of this plugin. Might be a solution? If yes, can you help me identify a script I need to exclude?

    • This reply was modified 5 months, 1 week ago by antontkachev.
    Plugin Author Pixelbart

    (@pixelbart)

    @antontkachev

    In general, nonces are used to ensure that certain actions do not occur more than once and thus can be exploited for malicious actions.

    However, Helpful still checks in its own way whether someone has already voted, so there should actually be no problems if you deactivate the nonces.

    It is just a bit safer to enable the nonces. But I don’t think it will cause any problems if you disable them for your intended use.

    On the server side, I can’t help you. I’m really just a builder, but not an scientist in all fields 😀

    Thread Starter antontkachev

    (@antontkachev)

    I got it, thanks for all the information. Will investigate further and see what I can do. You’re the best! Cheers.

    Plugin Author Pixelbart

    (@pixelbart)

    Well, without feedback you don’t become the best. That’s why we are all the best here!

    Have a great day and thank you! ✌

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.