WordPress.org

Support

Support » How-To and Troubleshooting » Can’t publish posts containing links

Can’t publish posts containing links

  • All of a sudden I can’t publish posts containing links.

    When I hit ‘publish’ I’m redirected to the homepage instead of staying on post.php

    Normally by inserting a full URL wordpress detects this and creates a hyperlink but this isn’t happening either.

    I have posts that contain links and there did not used to be a problem! Can’t think of anything I’ve done that could change things…

    Any clues..?

    the url is ukmoneypot.co.uk

Viewing 6 replies - 1 through 6 (of 6 total)
  • To add to this even if I just try to embolden some text the post fails and I just get redirected to the homepage??

    Having read more in this forum I need to add that my host says they have not upgraded mysql or php and I’ve tried turning off the rich text editor in ‘options’ and ‘user’ and it made no difference.

    If I type a URL using the RTE it picks it up and changes it to a hyperlink but as above, I can’t publish posts with links in.

    It’s as if it will only allow <p> tags and no others!

    I’m getting the same problem.

    http://wordpress.org/support/topic/114315?replies=2

    Is it something to do with the latest version of WordPress? It seems to be that whatever filters the text before posting is redirecting to the wrong place but I can’t solve the issue.

    Please help us both!

    Just had to dig a little deeper…

    http://wordpress.org/support/topic/76419?replies=21

    has the solution from Whooami of disabling mod_security by inserting a .htaccess file in /wp-admin/ containing:

    SecFilterInheritance Off

    This worked for me!

    Consider this closed!

    Your a star! It worked!

    Many Thanks!

    Thanks for this solution! Don’t know how I missed it when I searched the forums earlier, but this solved my problem!

    My Original Post

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can’t publish posts containing links’ is closed to new replies.