Can't Publish Pages or Posts (10 posts)

  1. Chiefwoodworker
    Posted 8 years ago #

    I am having problems publishing Pages and Posts. My most frequent error message is:

    Your attempt to edit this page: "About" has failed.

    Please try again.

    I get this message when I am trying to save a page or post. If I am attempting to publish the error message is the same except replace the word edit with publish.

    I am using WordPress 2.5 and the default theme. I have only changed the header and footer. Nothing else.

    Any ideas?

    My blog is http://www.srww.com/blog

  2. Keilya
    Posted 8 years ago #

    How about plugins? Tried disabling them?

  3. thelazygeisha
    Posted 8 years ago #


    Work backwards.

    Try running WordPress without your modifications to the header and footer to verify that the software is working correctly with your database. Then make your modifications one at a time and test them to see what you're doing to break the software.

  4. buzz
    Posted 8 years ago #

    I've been having this intermittent problem myself and across the three blogs that I have upgraded so far. I have noticed that when I get this message, the post is thrown into draft status. It would be hard to nail down a common plugin as the problem since it has been intermittent for me.

  5. juliohm
    Posted 8 years ago #

    Anyone got through this? I'm getting this error from a fresh WP install. I can't post anything. It keeps coming back with the message "Your attempt to edit this page/post: "whatever" has failed. Please try again.".

    Help, please.

  6. juliohm
    Posted 8 years ago #

    Ok, finally figured out. WP's autosave feature is messed up. I got it working after I disabled it.

    Open up /wp-admin/post-new.php in your text editor and comment the line


    so that it looks like the following


    Save it. Done. Hope it helps other people out there.

  7. stevehl42
    Posted 8 years ago #

    nope, still didn't fix my problem. I don't get any error messages or anything, it just will not simply publish any pages. i have no clue why, i changed nothing and it was just working a few days ago.

    any help is much appreciated:)

  8. Roger Coathup
    Posted 8 years ago #

    I had similar problems:

    I'd changed my site's url, restored the database, and then wasn't able to save / edit pages or posts (it just went to the site homepage with no changes made)

    This .htaccess fix in wp-admin did the trick for me, and it's working again:

  9. janakisound
    Posted 7 years ago #

    juliohm: Thank you! just as an fyi for others with this same problem:
    I got the same error too with publishing pages and not posts.
    I had to coment out the wp_enqueue_script('autosave'); line with the file:
    page-new.php(instead of post-new.php)

    it worked like a charm. thank you!

  10. NetRebel
    Posted 7 years ago #

    Thanks Juliohm, solved my problem AND the annoying auto-save that was really starting to piss me off. Constantly working on a mobile connection I don't want this kind of delaying behavior anyways.

Topic Closed

This topic has been closed to new replies.

About this Topic