Support » Fixing WordPress » Can’t publish from iPad text app via wordpress.com share app

  • todindiana

    (@todindiana)


    Trouble sharing to iOS WordPress app

    I have two WP sites. I use an iPad for a large percentage of computer use. When creating content for these sites, I prefer to use a 3rd party app to compose my posts, then “share” the posts to my blogs via the iOS WP app. I recently switched notebook apps to SnipNotes for several reasons. Trying to compose texts in either the browser admin or using the WordPress.com iOS app is like trying to row a boat with your hands, thus composing then sharing.

    My problem is that one of my sites rejects shares from SnipNotes while the other accepts all posts. There is one odd difference: The manual browser login procedure is different. When I access the login to one site, the login screen simply displays the “Username or email address” and “Password” fields. The login screen for the second site asks if I want to log in using my WordPress.com account, or if I want to log in using my email and password. It is this second site that rejects my attempts to automatically upload a post written in SnipNotes to the site. I have to wonder if it’s somehow related to the difference in manual logon procedures.

    Both sites have the Jetpack package installed and both Jetpack settings show that the sites are connected to wordpress.com. Running through the Jetpack Support tab, both sites display XML-RPC server accepts POST requests only. Both sites are hosted by the same hosting firm and are on the same server (they are actually subdomains off my main domain).

    The sequence of events goes like this:
    1. Type my text, including markup and shortcodes
    2. Tap the “share” option and choose the iOS WP app
    3. Select the target site, add categories & tags
    4. Tap “publish”

    For the site where this works, the post is published, WP exits, and I’m back in SnipNotes

    For the site where this fails, after tapping “publish”, a dialog box pops up stating, “Sharing Error. Whoops, something went wrong while sharing. You can try again, maybe it was a glitch.” Well, the glitch is permanent as this message pops up every time I try to share, even though the identical text worked fine with the first blog.

    A friend tried to do some troubleshooting and came up with these items:
    ====
    * I was able to reproduce the “Something went wrong” error on your site. The real error message is:
    The Jetpack site is inaccessible or returned an error: transport error – HTTP status code was not 200 (403) [-32300]

    * The WordPress app communicates with the WordPress server, which in turn talks to your site. The error code 403 means that your site replied with a “Permission denied” error.

    * I disabled the following relevant plugins without any effect:

    • BackupGuard Pro
    • W3 Total Cache
    • Webcraftic Clearfy
    • Workfence Security

    * I also (temporarily) removed all plugin code from your .htaccess file and tried to unblock the WordPress interface file “xmlrpc.php”:

    <FilesMatch “xmlrpc\.php$”>
    Satisfy Any
    Allow from all
    </FilesMatch>

    * The issue persists. I can now almost rule out that the problem is caused by a plugin or a bad configuration setting.

    I’ve also noticed that a POST request to your “xmlrpc.php” file returns a 301 redirect status instead of the usual 200 OK.
    ====

    Can you suggest any further troubleshooting steps that I could do to try to resolve this problem.

    If we cannot fix this, the it seems that my last resort is to delete my wordpress.com acount and disconnect my sites from that account. Then wait for a month and create that account again and see if that will resolve the problem. I can provide screen grabs but this data entry field doesn’t support them.

    Thank you for any ideas,

    Tod

    • This topic was modified 1 year ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not an Everything else WordPress topic

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can’t publish from iPad text app via wordpress.com share app’ is closed to new replies.