Support » Fixing WordPress » Can’t preview post

  • I’ve moved my WordPress index to my root at Every went smoothly thanks to folks here. But lastnight, while writing a new post, I attempted to preview and got in return:

    You do not have permission to preview drafts.

    There must be a permissions problem or a location problem? Everything else seems fine.

    Thanks so much

Viewing 10 replies - 1 through 10 (of 10 total)
  • When I hit preview post in the admin edit post panel of WordPress (doesn’t matter is post was saved or just loaded to revise) this is the url that pops up:

    Now, if I delete


    so the url is

    The preview shows up. But I shouldn’t have to do that. I have checked my user credentials, password, etc etc and have no idea why this is happening.

    Here’s the issue (in my case) I think it’s solved. All articles before the site address move – if revised after the site move will throw up this url and the preview will fail permission.

    However, any post written after the site url move will draft preview correctly.

    Hope this is helpful to someone else.


    The problem is not solved. It’s just different. For previewed posts after the site move – post preview appears to lose the post if you preview it. Great. 🙁

    So somewhere inside the bowels of the posting process – when the page is created to let you see the preview – there is a discrepancy of site address.

    And I have no way to know where this would be.


    If I want to preview a new post at my new url (the root) I get this:

    Not Found

    Sorry, but you are looking for something that isn’t here.


    And, I get the permissions denied bit.

    Is this a known upgrade to 2.8 issue?

    Backed up my site and reistalled 2.8 No joy.

    I am having this exact problem. Other posts suggest it has to do with 2.8.1 (I only today adjust my blog url to be different than my website url so cannot confirm).

    This is surprisingly frustrating — I’ve never had such a challenging problem with WordPress before. You never know how much you appreciate something until it’s gone. (1st world problem…)

    I have same problem.. how can i fix it..

    try to delete all cookies from your cache. restart the pc and log in correctly to your WP.
    It helped me to solve the same problem

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can’t preview post’ is closed to new replies.