Support » How-To and Troubleshooting » [Resolved] Can’t post/edit: requesting authentication “magic”

[Resolved] Can’t post/edit: requesting authentication “magic”

  • I’m getting a strange error when I try to post, or edit posts (or add/edit any content). I get a browser alert window that says:

    Authentication Required

    A username and password are being requested by http://mysite.com. The site says: “Magic”

    Then it requests user and password. User and password entry doesn’t work.

    I can log into the blog normally, without errors. I have reset my admin password, to no effect.

    Did I get hacked or something? How can I fix this?

Viewing 15 replies - 1 through 15 (of 29 total)
  • I fixed the problem by reuploading the root files, the wp-admin folder and the wp-includes folder from a backup of the site that I made a week ago. I didn’t touch the content folder.

    If you don’t have a backup, I imagine that if you download a fresh version from WordPress and recopy the files and folders listed above (being careful NOT to overwrite your wp-config file!), that would probably work, too. PIA, I know, but that’s all I know to do until someone else figures out the source of the problem.

    Also, to clarify — someone else pointed this out on another of my posts — by replacing the “root files” I mean the files in the top-level folder. Replace them all but the wp-config file.

    Ok, thanks. I’ll give that a shot.

    Seems like a strange problem to have just out of the blue.

    I was getting the same message as well. Even though I was already at 2.8.2, I performed the upgrade procedure, and now the message is gone.

    I uploaded the files you suggested, in 3 groups:

    1. root files
    2. wp-admin directory
    3. wp-includes directory

    I tested after each one. It start working until the last files (wp-includes directory). If it happens again, I’ll start there.

    Oops. I meant: It DIDN’T start working until I uploaded the wp-includes directory.

    Yeah I’m having this exact kind of problem right now, reuploaded /wp-admin directory – problem remains.. reuploaded root files – problem remains.. Right now reuploading /wp-includes directory – still uploading..

    I only got this issue after installing the Plug-in “Tweet This“, must have interfered with my other plug-ins?

    EDIT: Finished reuploading /wp-includes and the problem has been solved!

    i’m having the same problem. how do i re-upload /wp-includes? thanks!

    i am using WP 2.7.1 – can i upload wp-includes from WP 2.8.2 or does it need to be the wp-includes from 2.7.1? if so, where can i get that?

    @robk: Go to the WordPress downloads area and it should have the old versions.

    i got the “Magic” thing to go away, but now i am having issues with the sidebar and some other things on the blog. do you think it’s related? what else can i do to fix this problem? the blog i’m referring to:


    I assume this is some sort of attack as opposed to any form of error inherent to WordPress. I also fixed the problem for now by having it automatically reinstall WordPress.

    There’s at least one other post here discussing the problem:

    robk30: Maybe your problem with sidebars is related to this problem but I wonder if it is coincidental. I had problems similar to yours recently and ultimately found it was because some formatting codes in text I had pasted in from another site had messed up WordPress. You might try checking recent posts to see if there are any html codes included, or try temporarily removing your posts from 7/30 to see if that fixes the problem.

    Encountered the “Magic” problem with a client using v2.5.1 this morning. We, at least temporarily, solved the problem by reverting the wp-includes directory to a backup copy.

    We did a diff on the two directory and found that the vars.php file contained the infected code.

    Does seem like it might be malicious, doesn’t it? Simple fix…but I’m not sure that more damage wasn’t done. Fingers crossed, passwords changed, etc.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Resolved] Can’t post/edit: requesting authentication “magic”’ is closed to new replies.
Skip to toolbar