WordPress.org

Support

Support » Themes and Templates » Can´t post from home P2 Could not connect to WordPress SSL

Can´t post from home P2 Could not connect to WordPress SSL

  • First, Sorry to @andrew Nevins and @esmi was to hurry for help! my fault! 🙂

    Ok, I get this bug to day after upgrading WP core from 3.8.3 to 3.9, where I use the multisite mode with P2 v1.5.3. Also for my installation I use this plugin to set the https.

    Reading from the web many people recommend to reflush permalinks changing back to default and then again to post name, tried without a succes.

    Also think could be a browser problem, but try with Firefox, Chrome and Safari (all in OSX), again… nothing change.

    Most of the people have problems with the reply but in my case is just when I try to create a new post from home, frontend.

    Thanx for any help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Try to downgrade P2 to 1.5.2 but nothing. Nether deactivating the SSL plugin 🙁

    The error is on the file: inc/js.php at line 187.

    The original:

    $admin_url = admin_url( 'admin-ajax.php?p2ajax=true', is_ssl() ? 'https' : 'http' );

    Change to:

    $admin_url = admin_url( 'admin-ajax.php?p2ajax=true' );

    And is fixed 🙂

    The issue is happens if wordpress are behind a balancer (varnish, aws elb, etc..). Because the condition “is_ssl()” always says “FALSE”.

    We use the plugin wordpress-ssl and this plugin manage filters for the function admin_url. And, I think, don’t has any sense use “is_ssl()” in this line. Example, if you set https:// in the url of your domain, and you are behind the balancer this never works, with or without the wordpress-ssl plugin. Is better live the decision to use https or not to the admin_url function.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can´t post from home P2 Could not connect to WordPress SSL’ is closed to new replies.