WordPress.org

Forums

can't open install.php - Parse error: syntax...T_VARIABLE option.php...line 225 (8 posts)

  1. jamilac
    Member
    Posted 3 years ago #

    I uploaded a fresh wordpress and have checked the database a dozen times to detect if I slipped up there - can't find an error - and it's still producing the following message:

    Parse error: syntax error, unexpected T_VARIABLE in /homepages/17/d314178520/htdocs/sample1/wp-includes/option.php on line 225

    Curiously, using the same database but an older version of a wordpress site I had on hand, I found that install.php wouldn't function either, but, without the above error point to option.php. Instead, there was a more "official" error page explaining there was a database issue. Which may be the root issue here, but I'm struggling to find! (obviously have checked name, username password, host, verified it's up and running)

    Thank you in advance

  2. sanket101
    Member
    Posted 3 years ago #

    same issue from last 2 hours after manual upgradation to wordpress ..I googled the issue some say it is because PHP version of particular domain ... but I checked I do not have permission to set different php version to each domain so I wrote to web host ..they may help ....I will let you know the solution after their reply..

    if any one know then plz post

  3. sanket101
    Member
    Posted 3 years ago #

    Yes it is confirm this error came only because of older version of PHP
    I never changed PHP version but my blog hacked by someone and virus code added to my blog ..so i guess hacker changed my php version ...if u can't change your php then you need to contact your web host because WordPress requires at least PHP-5.2.4

  4. jamilac
    Member
    Posted 3 years ago #

    I was able to fix this by contacting my host, who advised me as follows:

    Upon further checking, the current version of PHP running in your server is 4.4.9. If you wanted to upgrade the version of the PHP, you can configure that by uploading the .htaccess file to the directory where your domain name is pointing to. To create the .htaccess file, you can use a text editor software, like Notepad, and you should insert the code provided below into it.

    AddType x-mapp-php5 .php

  5. MegWi
    Member
    Posted 3 years ago #

    I was able to fix it when I saw this post from esmi on another thread:

    "Haha! We have found a culprit thanks to some other gifted forum volunteers. There is indeed a bug in 3.4 that is only triggered on hosting that runs PHP 4 and PHP 5. That's certainly the case with 1&1. The gory details are available at http://core.trac.wordpress.org/ticket/21316 if anyone is interested.

    In shirt, we think that WP is trying to use PHP 4 and then erroring out when it should - instead - be generating a message along the lines of "You need PHP 5.2.4 to run WordPress". Since you're using 1&1, there may be a way around this. Try adding

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    an .htaccess file on your domain's root folder. That should force PHP5, if I remember correctly."

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    Please note that the fix I posted will only work on 1 & 1 hosted sites.

  7. trevstar22
    Member
    Posted 3 years ago #

    Is there any resolution for what to do since I'm not on 1&1? Is there any workaround?

  8. esmi
    Forum Moderator
    Posted 3 years ago #

    You need to speak to your hosts.

Topic Closed

This topic has been closed to new replies.

About this Topic