WordPress.org

Forums

Can't move page from Scheduled to Published (12 posts)

  1. jorhett
    Member
    Posted 3 years ago #

    It seems to be impossible to move a post from Scheduled to Published. If I have a post, and it's ready to go -- how can I make it be published on the site?

    Posts -> Edit - change Status to "Published" and Save -- nope, still Scheduled
    Posts -> Quick Edit - change Status to "Published" and Save -- nope, still Scheduled

    Posts -> Edit change Scheduled Time to less than one hour in the future -- doesn't publish
    Posts -> Edit change Scheduled Time to more than an hour in the future -- posts on time.

    This is repeatable on multiple instances of WordPress 3.2.1, including vanilla installations with no plugins.

  2. jorhett
    Member
    Posted 3 years ago #

    Note: no error messages, it simply doesn't publish the page.

  3. Digital Raindrops
    Member
    Posted 3 years ago #

    Anything with a post time in the future is scheduled?

    Posts -> Edit change Scheduled Time to less than one hour in the future -- doesn't publish

    What happens an hour or day later, it should publish, things to consider.

    If you have a caching plugin when will the cached pages be renewed and updated.

    The server and websites date and time locale are the same as yours.

    Test on a local install with no cache plugins.
    HTH

    David

  4. jorhett
    Member
    Posted 3 years ago #

    I can recreate this with no plugins. And no, I'm not using a caching plugin on ANY site.

    Server time and website time are the same. It's my system, I have root on the box ;-)

    And again, I *HAVE* a test install with no plugins at all, and I can replicate this problem. It's not a caching plugin. It's a bug in the code which prevents changing a Scheduled post to a Published post. No way out, you can't get there from here.

  5. Digital Raindrops
    Member
    Posted 3 years ago #

    What changes a post from Scheduled to Published it must be something like a CRON Job, is it something to do with CRON being disabled.

    My suggestions are just developer 'workflow logic' thoughts, things that I would be looking at.

    These are not the thoughts of an expert, I earn a living as a developer but not with WordPress or php, WordPress is just a hobby!

    But I would have thought that as a bug it would have been brought up before, have you checked trac?

    David

  6. jorhett
    Member
    Posted 3 years ago #

    No, a cron job doesn't move them from scheduled to published. Because there are no cron jobs for any of my wordpress sites and things scheduled hours in the future do publish on time.

  7. methodagile
    Member
    Posted 3 years ago #

    I have found a similar issue with WordPress version 3.2. I can create a post with a future date. After that date, the post moves from scheduled to published. However, the post is not published on multisites, so the post is not visible.

    Is there some mechanism that moves published posts to the correct wp_#_posts table, or is there a plugin that accomplishes this?

  8. suzanne@stoneflysystems.com
    Member
    Posted 3 years ago #

    jorhett - did you ever get resolution to your issue? I am experiencing the same issue. I like to check the development as I go and it makes it very difficult to check the layout.
    Thanks!

  9. jorhett
    Member
    Posted 3 years ago #

    My problem turned out to be a timezone thing. I had set it to GMT-8 but apparently this doesn't work properly, and you must select a city name in your timezone. Once I did this, publishing worked accurately and on time.

  10. jorhett
    Member
    Posted 3 years ago #

    There is still a bug in the interface about moving the item directly to published status. That's not fixed. But once you set your timezone to a city name, you can publish by scheduling it for a few minutes in the future.

  11. Loreen72
    Member
    Posted 3 years ago #

    Trying to fix this issue myself.

    I've deactivated ALL my plug-ins and fixed my timezone to be an actual city name. I still can't get any scheduled posts to publish.

    Any ideas on what to try next?

  12. jchybow
    Member
    Posted 2 years ago #

    If anyone is still having this issue, here is how I solved it:

    1) go to the WordPress Settings --> General and change your timezone to where you are (I chose city, but do not think it matters whether you choose city or UTC format)
    2) go to the WordPress Pages and select the page you want to publish. In my case, it was still "scheduled" for a time that had already passed.
    3) Edit the "scheduled" time to a minute or two from the current time
    4) The page should then publish as expected, but for some reason I then had to go to WordPress Settings --> Reading and set the front page as my desired page once again. (It defaulted back to "Your Latest Posts" for some reason.)
    5) just for the heck of it, clear your browser's cache.

    This at least changed the status of my page to "published" once again.

    EDIT: even after doing all this, using Safari 6.0 for Mac OS X Mountain Lion, I still wasn't able to visit my site to see how it looks right away. It took about 10 minutes before I could refresh and actually see the site. However for testing purposes try opening a different browser and after following the above steps, the site should come up right away.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.