Support » Fixing WordPress » Can't modify wordpress. Getting contributor behaviour instead of admin.

  • Resolved zmin


    Hi, i have a standalone wordpress installation which worked just fine until recently.

    Currently i can’t modify basic content, such as activating plugins, editing pages or deleting comments.

    Last actions I took were testing a contact form
    and getting an error.

    I can install plugins using the dashboard but I can’t activate them. Sometimes the pages appear in php code but i can’t seem to repro it.

    I also subsequently tried to modify the .htaccess (which is now 644) file but any attempt results in Internal Server 500 Error.

    It is currently

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Also when I try to add a new post, instead of Publish the button says Send for approval, and if i click that i get this page:

    Are you sure you want to do this?
    Try again

    The general user behaviour is that of an author/contributor, but I have admin rights. I can’t modify or add users. If I tryi to add a new admin users i receive a mail saying:

    New user registration on your website: Respiraţia Conştientă:
    User name:

    If anyone knows how to fix this please reply as soon as possible.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Try:
    – switching to the Twenty Eleven theme by renaming your current theme’s folder in wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    Thanks for the reply. I found the solution, It’s bit unexpected but who knows maybe it will help someone.

    The quota for the MySQL database size was reached so the hosting service restricted adding or modifying tables. I increased it and know i think everything works fine. 🙂

    Thank you for the quick support.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can't modify wordpress. Getting contributor behaviour instead of admin.’ is closed to new replies.