Support » Fixing WordPress » can't mark as spam or delete comments

  • I have one comment in total. It is spam. When I try to mark it as spam or delete it, a box comes up:

    Are you sure you want to do this?
    Please try again.

    When I click ‘please try again’ it just loops back to the comment. I am also getting emails every day from wordpress asking me to moderate the comment. Prior to this I would get several spam comments a week and would mark them as spam and the comment would go to the spam folder and then be deleted.

    I am using twenty-twelve theme. The only plug-in I have online back-up.
    lostonearth.info

Viewing 4 replies - 31 through 34 (of 34 total)
  • EssaySnark:

    You did give me a lot of things to try and that helped me home in on the source of the problem which I believe was somewhere in the database.

    Thank you.

    For anyone else who experiences this problem, here is a recap of everything I did and what finally worked:

    This is for beginners with a small, simple site like mine.

    WordPress Dashboard:
    1. Check Settings: Discussion to make sure you are set up to receive comments.

    2. Check that posts are set to enable comments: Posts: Bulk Actions: Check All: Edit: Comments: Allow Comments, Save.

    No success? Next:

    Now is a good time to create a backup (I did mine on WPOnline Backup plugin, which I suspect may have been part of the problem, I later backedup through DreamHost which also created database backup, Dreamhost also keeps several days database backups so you can restore from that if needed).

    Now is a good time to also export a copy of your posts and save on you computer or cloud service.

    Now, with everything backedup:

    WordPress Dashboard:

    1. Plugins: Deactivate all plugins. If this solves the problem, you can reactivate them one by one until you identify the one that needs to go!

    2. Updates: Reinstall WordPress. Check for success, if not:

    3. Appearence: Themes: activate a new theme. Don’t worry, everything will be all over, but when you switch back everything will be back in its proper place.

    These were the basic troubleshooting tips. You investigated if the problem was with settings, plugins, WordPress, theme.

    Now you need to work on your site from the back end through FTP.

    Here is a good source of information on using FTP:
    http://www.wpbeginner.com/wp-tutorials/how-to-fix-are-you-sure-you-want-to-do-this-error-in-wordpress/

    I used Cyberduck, which is for Macs.

    Cyberduck FTP:

    You will see three files, one has your website name. Open it. Now you see all the files that make up your site from behind the curtain. Don’t be afraid, you have a backup and can always go back to your broken site.

    1.Deactivate the plugins folder by renaming it ‘plugins.deactivated’ confirm by looking at your WordPress dashboard: plugins that the plugins are deactivated. Check site to see if problem solved.

    2. Remove the folder for your theme, allowing the default theme to operate. Check site again to see if problem solved.

    3. WordPress.org: download a copy of WordPress. Remove everything except the contents folder from your FTP files and upload a fresh copy of WordPress. Add the wp-config.php file from your backup and edit according to the instructions found here:
    http://www.wpbeginner.com/wp-tutorials/how-to-fix-are-you-sure-you-want-to-do-this-error-in-wordpress/

    Still not working?

    Next turn your attention to the database. At DreamHost, you have an option to repair and optimize your database. Try that. By now your head hurts.

    If that does not work, last big BLOW-OUT:

    Here’s what finally worked for me:

    1. Put your database up in one window.
    2. Put your backup up in another window.
    3. Put WordPress download up in another window.
    4. Put FTP connection up in another window.

    Now:
    1. Delete all the tables (not the database) in the database.
    2. Delete all the files from your site folder through your FTP connection.
    3. Upload to your FTP file all the files from your WordPress download.
    4. Copy to your FTP file the wp-config.php from your backup.

    This takes you back to hello. All content, media, plugins are gone. But you will be able to restore them. There will be a ‘Hello’ post on your site. See if you can leave a comment. I could.

    Next, I generated new keys for the wp-config.php using this:
    http://wordpress.org/search/secret+key+service
    and used the new keys to replace the ones in the file.

    You’ve been through the worst and can always go back to your backup.

    Then, I redid my header, widgets info, and I imported my posts. I had to re-import the media that went with my posts. I installed the Askismet plugin to help with spam. But this was just because I was afraid to mess things up. If I had to do this again, I would have uploaded the contents folder from the backup via FTP and if the problem re-occurred, I could just go back to square one if it did.

    This is a beginners solution. If anyone has a more elegant way around this, please let me know for future reference.

    And again, thank you to your help. I took a long time for me to get over that this was not as simple a some box I didn’t check. I was new to WordPress and had not customized anything and I only had one plugin. What could go wrong? After all this, I’m not afraid of the thing at all anymore. Delete your problems away and install new ones!

    lostonearth.info

    Or, you can First try this simple, possible solution that EssaySnark gave me in the last reply:

    http://halfelf.org/2014/not-the-bug-i-expected/

    I will keep this on file for future reference.

    Mika, thanks for stopping in! Good to know the secret way to get you alerted of threads here on the forums. Will be on the lookout in case any of these puzzler comment-behavior issues reoccur (good to know it’s not a Dreamhost thing after all!!!).

    missmarymac, congrats on solving your problem, and great to see you document everything so thoroughly – that can be so incredibly helpful when people come across a thread like this. Thank you for sticking with it and giving us all the update!

    Hopefully others on this thread have found their solutions too.

    I (also on Dreamhost) have been having identical problems to missmarymac and basically put it down to a failed update that would later sort itsself, but ultimately it was that link to halfelf’s page that fixed this for me.

    Link:
    http://halfelf.org/2014/not-the-bug-i-expected/

    Notice the various attributes for “comment_id”?
    http://i.imgur.com/DKx5K9V.jpg

    Well, mine looked like this:
    http://i.imgur.com/7jqZpNg.jpg

    So, I prettymuch copied it from the picture, to this:
    http://i.imgur.com/RUG5WG5.jpg

    And instantly, the spam started flooding in 😀
    Never have I been so happy to see it.

    I still can’t delete comments properly, and posts sometimes (probably due to caching?) will list “3 comments” after I’ve deleted them from the database, but hey, actual comments.
    I didn’t manage to salvage the old discussions, which is a shame, but thanks everyone.

Viewing 4 replies - 31 through 34 (of 34 total)
  • The topic ‘can't mark as spam or delete comments’ is closed to new replies.