Support » Fixing WordPress » can't mark as spam or delete comments

  • missmarymac

    (@missmarymac)


    I have one comment in total. It is spam. When I try to mark it as spam or delete it, a box comes up:

    Are you sure you want to do this?
    Please try again.

    When I click ‘please try again’ it just loops back to the comment. I am also getting emails every day from wordpress asking me to moderate the comment. Prior to this I would get several spam comments a week and would mark them as spam and the comment would go to the spam folder and then be deleted.

    I am using twenty-twelve theme. The only plug-in I have online back-up.
    lostonearth.info

Viewing 15 replies - 16 through 30 (of 34 total)
  • A shaman might help! πŸ˜‰

    Or maybe try exporting your posts, deleting EVERYTHING from the server, then reinstalling WP and importing the posts back in?

    It’s very suspicious that the backup you restored had content in it that was supposedly posted AFTER the backup was taken. There’s something wonky on your server (ghost in the machine?). I would have suggested a cacheing issue but you said there’s no plugins installed. That backup plugin you have should be ditched while you’re investigating all this. Is the backup you restored from the plugin or was it one saved by Dreamhost?

    Also an idea: Mika Epstein (ipstenu) is a WordPress genius; she works at Dreamhost. You could try reaching out to her through her site? http://halfelf.org/

    These are great ideas and they should work. Right?
    So here’s what I did:

    1. Via DreamHost webFTP: I removed all the plugins, even the ones I never activated.
    No change.
    2. I created a safety backup through DreamHost and downloaded a copy to my computer. Yes, the previous backups were all created using Online Backup for WordPress plugin.
    3. I exported all my posts.
    4. I downloaded an even fresher copy of WP 3.8.1
    5. Via Cyberduck FTP, I removed everything, contents folder, everything, and reloaded wordpress.
    6. I coped the wp-config.php from the DreamHost backup.

    And

    All my posts were still there but with all the photos (media) missing. And I couldn’t restore from the exported posts because ‘posts already exist’

    I uploaded the contents folder from the DreamHost backup just to keep everything up while I try to sort this out.

    Where is this content coming from? I would guess that is part of the problem. Technically, if I wipe everything clean, I should be able to solve the problem.

    I also looked at halfelf, it seems she works and sometimes helps with support questions in the forums. She recommends some professionals, if it comes to that. Which it shouldn’t for an itty-bitty little blog.

    If you have any more ideas, please! I appreciate your time and interest and your last suggestions, although they haven’t worked yet, may reveal what the true issue is.

    I think posts may exist in the database also, so that may be where they are coming from.

    I looked at my database and compared it to the one on:
    http://codex.wordpress.org/Database_Description

    My database appears to have extra copies of these files as well as some tables by the online backup plugin, although I can’t be sure if it is from the plugin or part of DreamHost’s backup.

    wp_comments
    wp_wgmi2w_commentmeta__20140303_034154
    wp_wgmi2w_comments__20140303_034154
    wp_wgmi2w_links
    wp_wgmi2w_links__20140303_034154
    wp_wgmi2w_options
    wp_wgmi2w_options__20140303_034154
    wp_wgmi2w_postmeta
    wp_wgmi2w_postmeta__20140303_034154
    wp_wgmi2w_posts
    wp_wgmi2w_posts__20140303_034154
    wp_wgmi2w_terms
    wp_wgmi2w_terms__20140303_034154
    wp_wgmi2w_term_relationships
    wp_wgmi2w_term_relationships__20140303_034154
    wp_wgmi2w_term_taxonomy
    wp_wgmi2w_term_taxonomy__20140303_034154
    wp_wgmi2w_usermeta
    wp_wgmi2w_usermeta__20140303_034154
    wp_wgmi2w_users
    wp_wgmi2w_users__20140303_034154
    wp_wgmi2w_wponlinebackup_activity_log__20140303_034154
    wp_wgmi2w_wponlinebackup_event_log__20140303_034154
    wp_wgmi2w_wponlinebackup_generations__20140303_034154
    wp_wgmi2w_wponlinebackup_items__20140303_034154
    wp_wgmi2w_wponlinebackup_local__20140303_034154
    wp_wgmi2w_wponlinebackup_scan_log__20140303_034154
    wp_wgmi2w_wponlinebackup_status__20140303_034154

    Any ideas?

    Nevermind,

    I went ahead and reduced the tables down to the 11
    listed here:

    http://codex.wordpress.org/Database_Description

    no change.

    I have the same issue with an practically clean install of wordpress, latest version.

    The interesting part is that the box:
    “Users must be registered and logged in to comment” is checked.
    The box
    “Anyone can register” is not checked.

    I am the only user at this point.

    The comment was made by Derrick %/hdkspjbhk805 31.134.253.132

    There may be some issue that does not enforce the rules.

    And then the leak somehow messes up the comment stack.

    To add more information:

    I received an email to moderate a comment today. I have been getting one of these every few days.

    As usual there is no comment in the dashboard nor is there a record in either of the comment tables in the database.

    This is so frustrating I am running into the same thing and I do also use Dream Host. Missmarymac I saw something about a nonce check not working properly
    Try:

    In the instructions on this site I do not understand what it is asking me to do as I am really new. So maybe you can try it out and if it works for you, you can tell me how to do it lol :)..

    I don’t know if this will help anyone.

    I was desperate, after a month+ of working on this and facing the possibility of spending money I don’t have.

    So, with all my new-found knowledge from reading hundreds of forums, help sites, tips…..I had only ten posts and a few drafts, so this might not work well for others, but I’d rather do this than another month of fruitless installing, and editing, and optimizing, and….

    I nuked it.

    1. I logged onto my DreamHost database, I did not delete the database, but I deleted all the tables.

    2. Via FTP (Cyberduck), I removed all the files. I uploaded a fresh copy of WordPress (content folder and all) and copied my wp-config.php from my DreamHost back-up (which I had downloaded to my computer).

    This took me back to the beginningβ€” “Hello”. I re-customized my theme (header, menu, widgets) and created a new post.

    I also activated Akismet (plug-in).

    Comments are working fine now. I will slowly rebuild the site, backing it up through DreamHost each step of the way.

    And maintain a positive outlook and thank the WordPress and DreamHost spirits.

    Sheheb,

    You’ll have to begin at the beginning. And hopefully your problem will be less intractable. I was a beginner too and it’s been a long two months of learning.

    1. Dashboard: Posts: Check All: Edit: Enable Comments, Save.
    2. Make sure Dashboard: Settings: Discussion, are set the way you want them.
    If this does not resolve:
    3. Access your DreamHost account and create a back-up. Download a copy to your computer if you can.(account backup is in the left side bar on the home page)
    4. Deactivate any plugins you have. Does this solve it? If it does, reactivate plugins one by one to find the problem.
    5. Dashboard: Updates: WordPress Updates: Reinstall now (will reinstall WordPress.
    Still not working?
    1. Go to your DreamHost webpanel: Web Administration: click on phpMyAdmin: click on your database: this will take you to your database tables: on the bottom it will say check all: ‘check all’ and ‘with selected’ pull down use ‘repair table’.

    Be patient, you will slowly learn a lot about how your site is put together. If these steps do not help, then write back. Good Luck!

    missmarymac and sheheb, if you are both on Dreamhost then that sounds really suspicious.

    @kpugh, are you on Dreamhost too?

    @missmarymac, we’re going to again suggest reaching out to Ipstenu (Mika Epstein) – yes she does often help out here on the support forums as a volunteer. Maybe start a thread with a title something like “Calling Ipstenu – help!” and link it to this? Can’t hurt! πŸ™‚

    If you read the post above my last one, starting with “I don’t know if this will help anyone.” You’ll see that I solved the problem and how I did it. This is possibly not a solution for everyone, but since I only have 10 posts and a simple non-customized site, I decided to try it (I did have backups of the site, the database, and had exported my posts for protection, so I could take it back to it’s original, albeit broken, state if need be).

    It is possible that I could re-import my posts now and have everything work, but I would rather just rebuild my posts.

    I am guessing the problem was with the database, so it may be a DreamHost problem. DreamHost, however, has been most unhelpful. As you may remember I had done as you suggested with getting rid of plugins and doing a clean install of WordPress via FTP. I also did many other things to try to fix it. Everything I did is listed in this thread.

    essaysnark, I thank you for your help. I have learned a lot.

    Congrats missmarymac!!!!! That’s huge – you should be proud of yourself. πŸ™‚ Really cool. (I did miss it, that you said you fixed your problem.)

    Coincidentally… (or not!): Mika posted on her blog today about a database error with comments… could this be the same thing?

    Not The Bug I Expected

    I admit that I didn’t dig deeply into your solution, missmarymac, nor did I read her post closely.

    Anyway, glad to hear you’re back in business! The “learning a lot” is great but here’s hoping for a “learning-free” site for you!!

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    I was at WordCamp Atlanta, HOWEVER, if you do see this at DreamHost, feel free to ask them “Can Mika take a look at this one?” That’s why they keep me here!

    I’m sorry we couldn’t solve it (and for last week’s backlog, we pulled in a lot of OT to catch up), but if it IS that error essaysnark linked to, it’s insanely weird, and I’m not 100% sure I know it’s cause yet. I’ve seen it on non-DH boxes now (yay?) so I know it’s not US so much as ‘something.’ Two people I KNOW were hacked, though, and one had a really old plugin that did backups in the stupidest way I’ve ever seen. It’s … weird. You know? Nothing WE do, and yes I did spend a week on that reviewing DB logs, edited the DB in that way :/

    Also if you tag a post with ‘DreamHost’ I get emailed πŸ˜‰ Fastest way to get me in my officially DH hat thingy.

Viewing 15 replies - 16 through 30 (of 34 total)
  • The topic ‘can't mark as spam or delete comments’ is closed to new replies.