Support » Fixing WordPress » can't mark as spam or delete comments

  • I have one comment in total. It is spam. When I try to mark it as spam or delete it, a box comes up:

    Are you sure you want to do this?
    Please try again.

    When I click ‘please try again’ it just loops back to the comment. I am also getting emails every day from wordpress asking me to moderate the comment. Prior to this I would get several spam comments a week and would mark them as spam and the comment would go to the spam folder and then be deleted.

    I am using twenty-twelve theme. The only plug-in I have online back-up.
    lostonearth.info

Viewing 15 replies - 1 through 15 (of 34 total)
  • Moderator t-p

    (@t-p)

    The only plug-in I have online back-up.

    try disabling that plugin for a moment.

    Thanks for your reply.

    I disabled the plug-in and even re-logged on but the same message appeared. I even logged on through Safari (usually use firefox, and yes it is up-to-date)

    Any other suggestions?

    I appreciate any help as I have been trying to figure this out on my own for two weeks now.

    Moderator t-p

    (@t-p)

    To rule out any theme-specific issue, try switching to the unedited default Twenty Fourteen theme for a moment using the WP dashboard .

    I have not customized the theme at all and so that may be why I don’t see anything in the dashboard that could allow me to revert to a default. Unless I’m missing something?

    Again, Thank you.

    Moderator t-p

    (@t-p)

    dashboard > appearance > themes

    dashboard > appearance > themes:
    This shows me available themes, twenty-twelve is first.

    The snapshot tells me:
    It does not need an update
    It is active
    and there is a button to customize. Going into customize only allows me to set basics within the theme— site&tagline,colors, header image.

    I don’t see anything about default settings?

    I have found a way to get rid of the comment using the WP-DBManager.
    I still cannot delete or mark as spam from dashboard > comments.
    It still asks me:
    Are you sure you want to do this?
    Please try again.
    and loops back leaving the comment as pending.

    Now I have discovered two new problems: There can only be one comment held for moderation at a time, if I try to send a second comment, even about another post, is does not ever show up, even after the first comment is removed. Also, after hitting ‘post comment’ I get a warning page:
    Warning: get_object_vars() expects parameter 1 to be object, null given in /home/mrstrauss/lostonearth.info/wp-includes/comment.php on line 171

    Warning: Cannot modify header information – headers already sent by (output started at /home/mrstrauss/lostonearth.info/wp-includes/comment.php:171) in /home/mrstrauss/lostonearth.info/wp-includes/comment.php on line 679

    Warning: Cannot modify header information – headers already sent by (output started at /home/mrstrauss/lostonearth.info/wp-includes/comment.php:171) in /home/mrstrauss/lostonearth.info/wp-includes/comment.php on line 680

    Warning: Cannot modify header information – headers already sent by (output started at /home/mrstrauss/lostonearth.info/wp-includes/comment.php:171) in /home/mrstrauss/lostonearth.info/wp-includes/comment.php on line 681

    Warning: Cannot modify header information – headers already sent by (output started at /home/mrstrauss/lostonearth.info/wp-includes/comment.php:171) in /home/mrstrauss/lostonearth.info/wp-includes/pluggable.php on line 896.

    Any help greatly appreciated. I’m very new to this, hopefully someday I’ll be able to help someone else.

    Still looking for help.
    In the meantime a recap of the problem and solutions I have tried:

    Everything worked perfectly until mid-January: I would receive several comments (dashboard > Comments) each day (mostly spam) and I would approve, edit, delete, or mark as spam.

    Now there are two problems:
    1. Only one comment can appear for moderation at a time, additional comments, even for different posts, never appear for moderation or anywhere.

    2. I cannot approve, edit, delete, or mark as spam. When I try to edit, I get “Oops, no comment with this ID. Go back” when there is clearly a comment. If I try to approve, delete, or mark as spam, I get “are you sure you want to do this? Please try again,” which simply loops me back to the comments dashboard.

    The only thing I can do is remove comments using WP-DBManager.

    Here is what I have tried so far:

    Through the dashboard:
    1. I deactivated all plug-ins (only one: Online Backup for WordPress)
    2. I reinstalled WordPress
    3. I changed my theme.

    Through Cyberduck FTP:
    1.I deactivated the plugins folder and confirmed that the plugins were deactivated.
    2. I removed the theme allowing the default theme to operate.
    3. I removed everything but the contents folder and uploaded a fresh copy of WordPress and edited the wp-config.php file according to the instructions found here:
    http://www.wpbeginner.com/wp-tutorials/how-to-fix-are-you-sure-you-want-to-do-this-error-in-wordpress/

    I did log on to administer the site from Thailand, Laos, and Cambodia from December 17- January 8, but I don’t see how this could cause the problem, especially now that I have replaced everything.

    Now I am out of ideas. I have tried my inexperienced best to solve this problem, but now I would really appreciate some help.

    It sounds like you’ve been trying the right things. This type of thing can indeed be frustrating!

    It looks like you’re running a cacheing plugin, which can be a candidate for some issues. You should turn that off or even delete it until you get your problem resolved.

    At risk of asking you to re-do the same steps, here’s what I would suggest:

    1. Via FTP, rename your plugins directory (something like “plugins-off”)
    2. Through the backend, switch to the Twenty Thirteen theme.

    Does the problem still happen?

    As you know from my previous post, I have tried all the steps you mention. But just for fun, I tried them all again.

    Did not solve anything.

    So for even more fun, I replaced everything with the back-up I created on 12/15/13 way before the problem began.

    Did not solve anything.

    Everything has now been deactivated, themes switched, fresh downloads of everything via FTP. Where could this problem be?

    To recap: People will submit comments, they appear to go through and I receive emails asking me to moderate these comments. However only one comment appears in the dashboard. If I try to delete it or mark as spam, I get “are you sure you want to do this? Please try again.”

    If I try to edit the comment I get: “Oops, no comment with this ID” when there is clearly a comment.

    If I try to quick edit a comment I get: “Warning: get_object_vars() expects parameter 1 to be object, null given in /home/mrstrauss/lostonearth.info/wp-includes/comment.php on line 171 -1 “

    If I try to unapprove I get: “Comment 0 does not exist”

    The only thing I can do is delete from the table using WordPress-DBManager.

    Something is wrong! But where!

    I’ve been having the same problem! It started with getting inundated with spam comments to moderate. They suddenly disappeared one day and now I have only one spam comment. When I delete it, it reappears (or it doesn’t get deleted…I used the check box to the side). There are no other comments to moderate. On top of that, all of the comments I did approve have disappeared.

    Just today, when I tried to delete (I used the delete button directly below the message) this single reappearing spam comment I received that recurring message: “Are you sure you want to do this?
    Please try again.”

    Not sure what to do and I’m fairly new at WordPress. Help?

    missmarymac do let me know if you find a solution!

    No, I have not solved the problem.
    It appears that I will have to hire professional help which sort of defeats the purpose of using wordpress for a small blog.

    This is the link to wordpress beginner:
    http://www.wpbeginner.com/wp-tutorials/how-to-fix-are-you-sure-you-want-to-do-this-error-in-wordpress/

    They list all the basic steps to take to try to solve the problem. I have already tried these as you see above, but they may work for you. I any event you need to try these solutions before you can move on.

    Please let me know if you find a solution.

    @gnfugate, what is your site? We need the URL in order to help. It’s possible that it’s the same issue as described in this post but we can’t tell just from your description that the cause is the same.

    @missmarymac, I know that you’ve tried most everything that people around here will suggest to you, but there’s one idea that I have. It’s possible that the file comments.php is somehow corrupt on your system. From your info above I can’t tell how you reinstalled WP; you said you did it through the dashboard, and at another point you said you restored a backup. And maybe you did what I’m going to suggest but I have to suggest it anyway: Did you delete all WordPress files from your server except wp-content directory and all its contents, then download a fresh copy of WordPress, extract it on your computer and upload the files inside the wordpress directory to your web server?

    The other suggestion if you haven’t done it yet: Contact Dreamhost and ask for help. They’re pretty good with WP stuff, they might be able to offer some suggestions.

    I contacted dreamhost and this is what they said:

    Hello,

    I sincerely apologize for the delayed response. We have a large amount of
    incoming support and it’s taking longer than usual to get through it all.
    But it sounds like you’ve already taken the basic troubleshooting steps
    to correct this. Since those have not solved the issue the problem is
    most likely with the database itself. It’s possible the posts table for
    example may not be set to auto-increment. That’s just a guess. I’m afraid
    this goes a little outside the scope of our support. We recommend you
    contact the WordPress forums here for more insight.

    http://codex.wordpress.org/

    If there is anything on our end regarding the server or logs you’d like
    us to check please let us know.

    Chris J.

    I did what they suggested. Did not help.
    Here is a complete recap of what I have done including the database work:
    Everything worked perfectly until mid-January: I would receive several comments (dashboard > Comments) each day (mostly spam) and I could approve, edit, delete, or mark as spam.

    Original problem:

    Now there are two problems:
    1. Only one comment can appear for moderation at a time, additional comments, even for different posts, never appear for moderation or anywhere.

    2. I cannot approve, edit, delete, or mark as spam. When I try to edit, I get “Oops, no comment with this ID. Go back” when there is clearly a comment. If I try to approve, delete, or mark as spam, I get “are you sure you want to do this? Please try again,” which simply loops me back to the comments dashboard.

    The only thing I can do is remove comments using WP-DBManager.

    Here is what I have tried so far:

    Through the dashboard:
    1. I deactivated all plug-ins (had installed only Online Backup for WordPress & WP-DBManager)
    2. I reinstalled WordPress
    3. I changed my theme.

    Through Cyberduck FTP:
    1.I deactivated the plugins folder and confirmed that the plugins were deactivated.
    2. I removed the theme allowing the default theme to operate.
    3. I removed everything but the contents folder and uploaded a fresh copy of WordPress and edited the wp-config.php file according to the instructions found here:
    http://www.wpbeginner.com/wp-tutorials/how-to-fix-are-you-sure-you-want-to-do-this-error-in-wordpress/
    4. Via FTP I installed a back-up I created on 12/15/13 — before the problem began (and strangely two posts created after the back-up still appeared, with just the photo missing)
    Leaving the contents folder from the back-up on 12/15/13, I again reinstalled wordpress

    After these steps > New version of problem:

    Now, not even one comment appears in dashboard > comments. However, one comment at a time will appear in the database tables.

    Here is what I tried at this point:

    I repeated all of the steps taken for the original problem above.
    Dreamhost > MySQL Databases> I checked, repaired, optimized and confirmed that auto_increment was set for the appropriate tables.
    I used the WordPress secret key generator to replace the keys I removed from wp-config.php according to the instructions found here: http://www.wpbeginner.com/wp-tutorials/how-to-fix-are-you-sure-you-want-to-do-this-error-in-wordpress/

    Anomaly:
    I installed the back-up I created on 12/15 via FTP before the problem began. There were two posts created after this back-up. To me, they should not be there, but they appeared so something is being stored/backed up elsewhere.

    And that’s where I am.
    my site is lostonearth.info

    Thanks essaysnark for you time and interest

    Just because this is so much more fun than working on posts:

    FTP connection via AjaXplorer (Dreamhost FTP connection):
    I downloaded another, fresher copy of WP.
    Replaced everything but the contents
    and generated new keys & salts for the config file

    repaired and optimized database.

    no change.

    maybe I need a shaman.

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘can't mark as spam or delete comments’ is closed to new replies.