Support » Alpha/Beta/RC » Can’t Manage Widgets; Buttons Don’t Work in 2.7-hemorrhage

  • drew

    (@admaust)


    On the widgets admin page (/wp-admin/widgets.php) the only buttons that are clickable are ‘Search Widgets’ and ‘Save’ for Samsarin PHP Widgets. The rest are unclickable and I am unable to add, remove, edit, and rearrange widgets. I tried deleting my widgets.php file and uploading the widgets.php from 2.6.1 and then from the svn repository for 2.7 and that did nothing.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Jowy

    (@jowah)

    I’m addressing this issue as well, i kinda tried on my own to edit code, replace stuff but unsuccesfully~

    Evita

    (@evita)

    Same for me with FF3.1 and IE7, but it works with Opera. For sure it´s a JavaScript issue.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Works perfectly well for me in FF3 and IE7. Latest SVN, I just updated it from trunk right now.

    Evita

    (@evita)

    Well I think it depends on your own browser settings and also on the plugins used in WordPress – I´m using 24 plugins on a live blog with 2.7 and all of them are working without major problems. But I will update and see if widgets will also work for me.
    And let me say, 2.7 is very very cool, I love it. Great work of the team.

    drew

    (@admaust)

    Thanks. I appreciate all your comments and to know that it’s not just my blog is encouraging. After reading the comments above, I deactivated all my plugins and re-activated them in groups, and now the widget page is working normally.

    It first worked with all plugins deactivated and has continued to work as I’ve re-activated them. Hopefully, the same solution can work for the above affected.

    drew

    (@admaust)

    So Samsarin PHP Widget 1.3.2 seems to be the problem. Everything was working until I enabled it. Try just disabling it.

    Jowy

    (@jowah)

    i dont have above plugin, disactivated/reactivate everything and it’s still broken.
    Using Firefox 2.0.0.16 (i refuse to use FF3 atm)

    200% is some code getting in conflict with Ajax, had this issue before with Dashboard and a plugin

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Use the PHP Code Widget instead. It’s simpler, but it gets the job done. And simple usually means “still works”. 😉

    drew

    (@admaust)

    Works great! Thanks

    I’m having a similar problem with the plugin nextgen-gallery.

    The problem occurs on ubuntu/64bit/FF3, vista/FF3, xp/FF2
    No problem with vista/IE7 or xp/IE6

    Using wp2.7 from 2008-10-08

    I’ve just installed 2.7 on a testblog.

    Is there a way to display both sidebars on the widget page (like in 2.3) so you can drag and drop between them?
    If not, then it needs to be there. HAS to be there. It’s the single biggest complaint from all my users (I host multiple sites) and it’s the number one reason for all of us to not upgrade to any new version so far.

    Sorry, but give me a damn good reason why we can’t have the widget interface from 2.3 back?

    2.7 has a lot of improvements, but the widgets still suck the way they are. I want to see both sidebars at the SAME time, not switch between them. I want to be able to drag a widget from one bar to the other, into the position I want it.

    I’m also having trouble managing widgets. It’s a fresh install, well upgrade, and even with all plugins turned off and switching themes it’s assuming there are 7 widgets enabled – pages, archives, search and three category widgets.

    Other widgets I can use, but these are assumed as being used but don’t show up anywhere for me to deactivate or switch.

    I’ve also played with it in several browsers – all produce the same results.

    i have the same problem pawoodster

    I’m having the same problem as pawoodster and atomicfun. i can’t edit or move or remove several widgets – some of which i’m told are in use (they’re not) and vice versa…. wha…?

    btw, a screenshot:
    http://screencast.com/t/yceDbwybf3v

    This is with all plugins disabled, and using Opera, which i just installed for this purpose…

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Can’t Manage Widgets; Buttons Don’t Work in 2.7-hemorrhage’ is closed to new replies.