WordPress.org

Forums

All In One WP Security & Firewall
[resolved] can't login with secret word redirects to main page (9 posts)

  1. menusplus
    Member
    Posted 1 year ago #

    When I enter my secret word url I am directed to the main page of my website, I cannot get to WordPress login. How do I get to the wordpress login? Using mysite.com/wp-admin or mysite.com/wp-admin.php I get redirected to the main also. How can I access my site?

    http://wordpress.org/plugins/all-in-one-wp-security-and-firewall/

  2. wpsolutions
    Member
    Plugin Author

    Posted 1 year ago #

    If you have enabled the cookie-based brute force prevention feature then please read and watch the video here:
    http://www.tipsandtricks-hq.com/all-in-one-wp-security-plugin-cookie-based-brute-force-login-attack-prevention-feature-5994

    If you feel you need to restore the .htaccess file then see this:
    http://www.tipsandtricks-hq.com/how-to-restore-the-htaccess-file-when-using-the-all-in-one-wp-security-plugin-5945

  3. menusplus
    Member
    Posted 1 year ago #

    Yes, I watched and read. I removed All in one from the htaccess file and was able to get in. Then set it up again, then was able to log in. However a couple of days later the same thing happened, could not login just directed to the main page of my website. WHY does this happen?

    I also have WP Better security installed as well and I keep getting file change warnings as follows:
    wp-content/bps-backup/logs/http_error_log.txt Friday January 3rd, 2014 at 10:18 am UTC 7c9fc4a6772a4b4f07f2db937fcd19c5
    wp-content/plugins/all-in-one-wp-security-and-firewall/logs/wp-security-log.txt Friday January 3rd, 2014 at 6:37 am UTC c1bcd8d096efe52c02be01c227a1ee56
    wp-content/plugins/all-in-one-wp-security-and-firewall/logs/wp-security-log-cron-job.txt

  4. wpsolutions
    Member
    Plugin Author

    Posted 1 year ago #

    However a couple of days later the same thing happened, could not login just directed to the main page of my website. WHY does this happen?

    Depending on your site's setup, you have to be careful to ensure that you include "www." if necessary or leave it out when typing your URL with the secret word.
    So in other words, you would have to try one of the following:

    www.yourdomain.com?yoursecretword=1

    OR,

    yourdomain.com?yoursecretword=1

  5. wpsolutions
    Member
    Plugin Author

    Posted 1 year ago #

    Also I forgot to add that you should check that your browser has the cookies enabled.

  6. lreice@gmail.com
    Member
    Posted 8 months ago #

    This

    "www.yourdomain.com?yoursecretword=1"

    is a critical piece of information. I spent over an hour searching and trying different solutions

    .htaccess restore did not work btw. "question mark" secretword=1 is what it took. I don't understand why ...wouldn't the secret word be enough?

  7. inscan
    Member
    Posted 8 months ago #

    I think same problem, I have change url address for login page.
    On the first time setting (3 days ago), its able login using that address.
    But today I want login but always direct to homepage.

    I have try follow tutorial to wipe out all the firewall (edit .htaccess) still not able login using wp-login.php (page not found).

    Any one can help me ?

    Thanks

  8. esmi
    Forum Moderator
    Posted 8 months ago #

    @inscan: It is considered impolite to interrupt another poster's ongoing thread unless you are posting a solution or suggestion. As per the Forum Welcome, please post your own topic.

  9. inscan
    Member
    Posted 8 months ago #

    Ups sorry, I dont know that, i'm newbie here.

    thanks for attention

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic