WordPress.org

Forums

[resolved] Can't login - warning in capabilities.php (3 posts)

  1. jimre
    Member
    Posted 9 years ago #

    Fresh install of 2.0.2 on a hosted server. Installation completes successfully, database tables created successfully, am able to view the blog. But when I try to login in as admin, I get the following error(s):

    Warning: Invalid argument supplied for foreach() in /home/virtual/site356/fst/var/www/html/wordpress/wp-includes/capabilities.php on line 19

    Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site356/fst/var/www/html/wordpress/wp-includes/capabilities.php:19) in /home/virtual/site356/fst/var/www/html/wordpress/wp-includes/pluggable-functions.php on line 274

    Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site356/fst/var/www/html/wordpress/wp-includes/capabilities.php:19) in /home/virtual/site356/fst/var/www/html/wordpress/wp-includes/pluggable-functions.php on line 275

    Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site356/fst/var/www/html/wordpress/wp-includes/capabilities.php:19) in /home/virtual/site356/fst/var/www/html/wordpress/wp-includes/pluggable-functions.php on line 247

    I've searched this forum, and found several similar issues, some of which are still unresolved. I've tried the FAQ suggestion on the Headers already sent problem. No change. I've deleted everything from the server, downloaded & unzipped a fresh copy & started over. Same problem. I've confirmed that "capabilities.php" is not corrupted and has no extra whitespace.

    Maybe it's something with my hosted server? Running phpinfo() says it's PHP ver 4.3.10. It does not appear to be running the Zend Optimizer. phpMyAdmin shows that MySQL is ver 3.23.58.

    I've tried everything I can think of, and can't get past this warning. Any ideas?

  2. jimre
    Member
    Posted 9 years ago #

    Well - this is finally fixed, with the help of my hosting company (www.isomedia.com). The issue was that "Magic Quotes" were enabled on my server's default PHP settings. Seems like WordPress ought to deal with this stuff automatically, regardless of random server defaults - oh well, I guess not.

    The specific solution was to add some lines to the .htaccess file in the /wordpress directory:

    php_flag magic_quotes_gpc off
    php_flag magic_quotes_runtime off

  3. josedante
    Member
    Posted 8 years ago #

    I'm afraid that may solve the problem for those on a linux server. But what about us on windows. My life's been wrecked by this bug.

Topic Closed

This topic has been closed to new replies.

About this Topic