Can't Login to Dashboard - wp-admin redirects to wp-login.php (3 posts)

  1. drunkenmeatball
    Posted 3 years ago #

    For some reason, this problem is only happening with Chrome. It was just my home computer for a while, but today it's also a problem on my work computer. I've deleted the cache, the cookies, the browsing history, even my saved passwords, and nothing helps. I've uninstalled and reinstalled all plugins one by one, and tried a clean install of WP. My blog is in a subdirectory of my website (mysite.com/blog) and both the WP address and site address are that. The blog itself isn't having problems and shows up to my readers just fine.

    The issue is that when I try to go to my admin login page, (mysite.com/blog/wp-admin), it redirects to http://mysite.com/blog/wp-login.php?redirect_to=http%3A%2F%2Fmysite.com%2Fblog%2Fwp-admin%2F&reauth=1 and I am unable to login. It's like pressing the button does nothing, because the page doesn't even show that it's loading. I also can't click on the "Remember Me" check box. The URL redirect is happening on all other browsers I've tried (Firefox, IE9, Opera, Safari), but I am able to login still on the other browsers (for now).

    I know the easy solution is to just use Firefox instead, but I'm afraid that I soon won't be able to login using that either. I haven't installed any plugins recently, though I did delete the W3 Total Cache plugin (as it was giving me other problems a few weeks ago) recently. I haven't changed any settings since yesterday (this issue wasn't happening then), and I have already contacted my hosting provider and it's not an issue on their end.

    the link to the page that's having issues, if it helps, is kristibeck.com/blog/wp-admin

  2. drunkenmeatball
    Posted 3 years ago #

    Any help would be appreciated...

  3. stanhanks
    Posted 3 years ago #

    I'm was having exactly the same problem. Research via Google said the likely problem was a plugin, so to fix it, I loggged into my server directly, went to the wp-content/plugins directory, made a new directory called "Disabled", and moved all my plugins into it, then restarted the httpd service.

    The expected login screen came right up, and I was able to log in. Of course, when I go to the "Plugins" management tab, there's a pile of errors because it can't find any of the plugins, so I'm putting them back one at a time and checking to make sure it's still working. That's going to take a while, but since I was already here, I thought I'd share what I found that worked.

    This is unusual -- it was working fine last week, and this week, not. Without me making any changes, applying updates, etc. I wonder what changed?

Topic Closed

This topic has been closed to new replies.

About this Topic