WordPress.org

Forums

[resolved] Can't login to admin after new install - need holy water! (14 posts)

  1. mangozilla
    Member
    Posted 6 years ago #

    I'm having the same issues that have been reported by so many others, yet can't seem to find a fix for mine. May be related to the location of domain on server?

    The issue is that after uploading files to server on a new install of WP 2.6.2, I'm able to get to the installation url, enter blog title & pw,and get to the login screen. At that point entering login & pw just returns me to the same login screen. However, I was able to successfully login from a separate pc. I know - sounds like a cookie issue, but...

    I already have one blog (mydomain.com/blog) that's been going fine for the last month - no issues there. The mydomain.com index file is in the root directory. I bought 2 domains from the same hosting company, and directed them to home directories in the root (/newdomain1, /newdomain2). Installed WP2.6 files in /newdomain1 and /newdomain2.

    After browsing other forum posts describing a similar or identical issue, here's what I've tried:
    - cleared cookies & cache in Firefox
    - delete plugins from the Plugins folder
    - confirmed 2 separate url's for accuracy in the database (they were accurate)
    - changed security keys in wp_config.
    - tried accessing with IE browser.
    - delete and reinstall wp files.
    - download & install new wp files
    - added the line, @define(’ADMIN_COOKIE_PATH’, ‘/’); to the wp-config file (then removed it after no results & reading about possible security issue)
    - installed wp2.6.1, which I use for my existing blog
    - reboot
    - kick stuff & curse

    Still exact same results with both new blogs. I've seen several related threads with a few people reporting fixes that seem to be unique to them alone, while others still struggle... I'm one of the others. Any suggestions I haven't tried yet?

  2. keyone
    Member
    Posted 6 years ago #

    I was also unable to log in. I tried resetting my password, but still no luck. I moved to another PC and was able to log in. Very weird.

    Here's how I fixed it:

    In Firefox, go to Tools > Options
    Click on Privacy Tab
    Then click on Show Cookies button
    Find your domain. Highlight it and click Remove Cookies. You could probably remove all cookies, but I didn't want to do that.

    Then close all Firefox windows and am now able to log into my admin! Yeah!

    For IE7, do this.

    Close all IE windows.

    Go to C:\Documents and Settings\Carol\Cookies
    (This is for Windows XP, substitute Carol for your windows logon identity)

    Find ALL the cookie files associated with your domain. (use the windows search feature for this if necessary) Delete them.

    Reopen IE7 and it works! YEAH!

  3. mangozilla
    Member
    Posted 6 years ago #

    Yep. That was the first on my list of things I tried. Any other ideas?
    Oh yeah. I forgot to add "changed password" to my original list of things I tried (not getting password error, just no login - so not the issue).

  4. mangozilla
    Member
    Posted 6 years ago #

    ...and one more thing. Since I already have a blog as a subdirectory in the root domain, I wondered if that's creating conflict. Tried using pw for that blog, and received ERROR: Incorrect password.
    ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.
    Bad password error was expected. I confirmed that cookies ARE allowed in FF and then specifically enabled cookies from that specific domain.

    Issue still remains.

  5. Ragster
    Member
    Posted 6 years ago #

    This may not be related - but I had a similar experience recently.

    I asked my hosting company to have a look and they found something wrong there - I'll post the reply before as it all a bit gobbldeygook to me - but they DID fix it...

    The IP with which the DNS records of domain xxxxxxxx.com was created on our nameservers were incorrect and now I had it corrected with the correct IP. Please note that it would take about 24-72 hours for the corrected DNS records to get propagated globally, until then you may check the domain via any proxy sites and verify if it is correct or not.

    Good luck!

  6. mangozilla
    Member
    Posted 6 years ago #

    NEW INFO THAT NARROWS POSSIBILITIES:

    I uninstalled and reinstalled Firefox browser, and successfully logged into the first NEW blog I installed. Then tried to log into my original, ongoing blog (which had no previous login issues) on the same server but could not. No luck on any other blog. That login set something somewhere, because I opened up IE browser and got the identical new results - admin access only to the blog just accessed via Firefox, and no login access to any others. So something is telling both browsers about the first admin access that prevents other access.

    What setting could effect each browser this way? And how can I fix it?

  7. mangozilla
    Member
    Posted 6 years ago #

    Summary: Login access to any ONE of three blogs installed on same server (only 1 in root, but no subdomains). Can change the blog I gain access to by reinstalling Firefox and logging into any blog, which becomes the new one & only one I get access to. Using IE produces same result.
    Admin access to all three blogs using different PC (not mine) running Windows2000 (WinXP on my PC). Clearing cookies, cache, and flushdns fails to resolve. I have to believe there's someone who can ID the solution. (pleeeease!)

  8. mrmist
    Forum Janitor
    Posted 6 years ago #

    What is the structure of your 3 blogs, and what versions were/are they at now?

    If I get some time I will attempt to replicate the installation on a test server.

  9. neville
    Member
    Posted 6 years ago #

    My experience in upgrading one of my blogs from 2.6 to 2.6.2 is similar although the circumstances don't look the same.

    It seems that my lock-out (the endless login loop) was due to a security exploit, according to the support folk at my hosting service, DreamHost.

    I've written a post that explains the issue and the fix I implemented at DreamHost's suggestion -

    http://www.nevillehobson.com/next/2008/09/13/the-endless-wordpress-login-loop/

    And here's another situation and fix -

    http://johnhawkinsunrated.com/fixing-the-wordpress-login-issue

    Hope these are of some help.

  10. mangozilla
    Member
    Posted 6 years ago #

    @mrmist - thanks for the offer. All three blogs on my host server are WP 2.6.1. The two new blogs are brand new installations, and when I had trouble after installing 2.6.2 I deleted and reinstalled with 2.6.1, which remains now.

    Blog #1. (the original) - is a subdomain of a website I have (i.e., firstdomainname.com/blog). The index.php of the web site is in the root, and then the blog is in /blog#1.

    Blog #2. Domain is domainname#2.com, and installed in /blog2
    Blog #3. Domain is domainname#3.com, and installed in /blog3

    At this point the issue seems to be isolated to my laptop, since I don't experience the trouble using an offsite pc or even an old desktop I also have here at home. Haven't tried taking the laptop to a wireless access point coffee shop, or something. I just can't figure out what setting would be placed on my pc that remains regardless of browser, even after clearing cookies, cache, & flushdns. Also ran Spysd today - no help.

  11. mangozilla
    Member
    Posted 6 years ago #

    @neville- thanks. I read your post, & think mine's a different issue. Not related to an upgrade, but a new install, and never had anything older than WP2.6.1 on my host server. Ihad also read your reference to the post citing "load balanced behind an ssl accelerator the SSL is added through the appliance and the apache/php install knows nothing of the https. I edited the two rows in the wp_options table that had http and changed it to https." That's pretty far over my head, but looked at the options table, found only 1 http reference, changed it to https, resulting in the login error:
    SSL received a record that exceeded the maximum permissible length.
    (Error code: ssl_error_rx_record_too_long)
    The page you are trying to view can not be shown because the authenticity of the received data could not be verified.

    Again, don't know what that means but I changed it back...

  12. mangozilla
    Member
    Posted 6 years ago #

    FIXED: It's a FIREWALL issue. I don't understand the symptoms, but the fix was to shut down the firewall. I use CA ETrust Internet Security Suite, which includes Etrust Anti virus and Etrust Firewall. Shutting down the firewall let me resume access to the blog admin panels. I still leave the Windows firewall active. I'm not sure about any sucurity issues this may cause, but at least I can get in.

    I hadn't seen this solution (or probably better stated, a "workaround") presented in numerous other login issue posts or on the WP troubleshooting pages. I hope this can help someone else.

  13. ausetkmt
    Member
    Posted 6 years ago #

    I had similar issues; luckily I had created a seperate log in id and it allowed me to log in after the upgrade locked my primary id out.

    this is such a strange issue with so many folks having it that it needs special attention. like wow !

    I had the issue on a freshly installed blog and have decided to wait until tomorrow and try to install and do it all again. this is not a random issue as it appears.

    hopefully the wp wizards are at work on a fix as we wait,

  14. bartel88
    Member
    Posted 6 years ago #

    I install 7.2.1 in my domain. I have copied over the pages from the site I built in WP.com, then deleted it.

    Now when I try to login to the admin at my domain, it redirects me to the login page at WP.com

    Please tell me how I can fix this.

    thank you

Topic Closed

This topic has been closed to new replies.

About this Topic