WordPress.org

Support

Support » How-To and Troubleshooting » Can’t login. Sends me to a blank page!

Can’t login. Sends me to a blank page!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Almost same problem here.
    I can login with FireFox with no problem but when i try to login with IE then it sends me to login (same) page again.

    Hello?? Any WordPress hotshots out there? This problem is ALL over the Support forums, and it is clearly a bug. NONE of the fix-it suggestions have worked on a clean, new install of WordPress with NO plugins, extra themes, nada, zero, zip. As per everyone else, wp-login.php brings up the correct login panel, but once filled out with user name and password, returns a blank wp-login.php. Viewing page source shows no code. This happens in both Firefox 2.0.0.3 and IE 7 fully patched. Navigating to any other page in the /wp-admin/ returns “” with no code visible via viewing page source. Hey WordPress – this is TOO COMMON a problem to ignore, and deleting plugins and renaming directories – if I HAD any to delete or rename – is a shameful way to solve things. FIX IT.

    Try changing the redirect link in the wp-login.php file. Other than that i haven’t got a clue what could be causing it

    “Hey WordPress – this is TOO COMMON a problem to ignore, and deleting plugins and renaming directories – if I HAD any to delete or rename – is a shameful way to solve things. FIX IT.”

    First of all, demanding things by shouting at people won’t help your cause.

    Secondly, here’s a tip: turn on your error reporting and look at your webservers error logfile. That will often tell you what’s gone wrong and where you should start looking next.

    Sorry you don’t like my “shouting”. However, with all of the other posts throughout the support forums asking for help on this same issue I think it needs to be taken more seriously. Some of those posts go back aways; this isn’t a new issue.

    So, thanks for the suggestions, but the two are complete dead-ends. Redirect to what? Every file that is brought up in the blog wp-admin directory shows “” with no code. So redirecting away from a blank page to “” doesn’t really help me set it up and do entries.

    The error log, with the original installation AND a fresh install AND another fresh install using SetupWP (excellent program, highly recommended) shows … exactly zip. No errors recorded (regarding WordPress) on any of the installations and subsequent attempts to log in.

    So, in the effort to get my client up and running, I’ve had to resort to b2evolution – which installed flawlessly.

    I still would like resolution on this though; despite the hours wasted on this install it is my preferred blogging software.

    This is and isn’t a bug… Check out the solution at my blog. Sorry – don’t feel like typing it all over again.

    Thanks Justin for the tip (renaming plugin folder and retrying login). In my case it turned out to be the Bad Behaviour (v2.0.7) plugin.

    My problem: WordPress v1.5.2 Login stopped working suddenly after 1.5 years without problems. No new plugins or code changes had been made. wp-login.php would just hang in an infinite loop and eventually timed out or my browser would offer me the actual wp-login.php file to open or save.

    Solution: Renamed the /wp-content/plugins folder. Retried login. No problem this time. So I turned off plugins one-by-one until login worked correctly again. Turned out to be Bad Behavior v.2.0.7 was ‘behaving badly’. Upgraded to Bad Behavior v.2.0.10 and everything is now hunky-dory.

    stitzelj

    @stitzelj

    Thanks for this, peterVG. Turns about Bad Behavior 2.0.10 is now behaving badly, as well. Took me several hours of troubleshooting and searching the forums here to find this. That was just the ticket!

    Yep… it’s some code in a plugin I modified. I obviously messed things up.

    The Fix: Just rename your plugins directory and start adding back in plugins until you find the culprit.

    This was also causing my problem with TinyMCE failing to load and not showing up anymore. Thanks Justin!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can’t login. Sends me to a blank page!’ is closed to new replies.