WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Can't login into wp-admin – Undefined Function?!

[Resolved] Can't login into wp-admin – Undefined Function?!

Viewing 11 replies - 1 through 11 (of 11 total)
  • I’d try to upload the wp-admin/includes again manually.

    Thank you for your advice, but I just tried it – and it doesn’t change anything. [The file that I uploaded is the same as I downloadet now that I wasn’t smart to do the backup in time :)].

    Of course, but perhaps the file got corrupted during the upgrade. Another option is to download the WP pack anew, perhaps the file got corrupted during download/unzipping.

    What did you do before this happens, nothing at all, upgrade, add a plugin or a theme. Don’t worry about the posts, they’re savely in the database, you just need to get WP working again.

    I tried to do the automatic update from WordPress 3.0.5. to 3.1. I’ll try downloading the pack manually. It has nothing to do with the theme, right?

    I expect not, but you can always try by activating Twentyten. Just rename the folder of the active theme using FTP or the file manager of your control panel and the theme will revert to Twentyten.
    But like I said, I don’t expect it to be the theme.

    Still no progress. 🙂

    I tried to download und unpack 3.1 manually and I did reupload the menu.php-file with no luck. Line 10 in ‘the original’ and in ‘new file’ are identical. I thought it was a 3.1 problem, so I tried to find the same file in an older version i did store 3 months ago – but I couldn’t fint one.

    To me it seems like I have to change something in those lines described, the words in between parenthethes are marked in red.
    I just don’t know what to write to make the action work?

    Again – thank you for trying to help!

    Try the normal troubleshooting route. Change theme to Twentyten, disable all plugins, that sort of actions. You can do both these things by renaming the foldernames of your active theme and the plugins folder in general using FTP.

    Just tried deactivating all plugins and renaming the theme to twentyten – it changed looks, but it did not help me to log in to the dashboard. Same error message, no changes.

    I have deleted all nonactivated themes from the ftpserver too.

    I’m thinking of reinstalling 3.0.5, but I don’t know how to do it? Would i be a good idea anyway?

    esmi

    @esmi

    Forum Moderator

    Your upgrade did not complete successfully.

    Try:
    – switching to the Twenty Ten theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides. You may need to try logging into your site to get this to kick in fully.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    – re-running the upgrade manually using wp-admin/upgrade.php.

    Wow – I’m back in the game! Thank you all for your help, I had to do a whole bunch of down- and uploads (and lots of cyberduck-problems: it doesn’t allow me to upload folders??), but I’m now able to log in!

    I can see now that some chanches happened, the new admin-bar is added, but it still tells me in a notification that

    “An automated WordPress update has failed to complete – please attempt the update again now.”

    I feel a bit afraid to try again, but well. I guess that I have to.

    Thanks again everybody!!
    Sandra

    Helped me too, thanks! I’ve noticed three of my sites suffered serious problems like this after trying to auto-upgrade to 3.1.1.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Can't login into wp-admin – Undefined Function?!’ is closed to new replies.