WordPress.org

Support

Support » How-To and Troubleshooting » Can't login – Error: Cookies are blocked…

Can't login – Error: Cookies are blocked…

Viewing 14 replies - 1 through 14 (of 14 total)
  • esmi
    Forum Moderator

    @esmi

    Try asking your hosts about this. Something may have changed at their end.

    I wrote to my host over 4 hours ago and they have not responded. We’ve been back and forth on this issue over the past few days with no solution in sight.

    Meantime, I’ve reset to a new password by doing the “forgot password” but it’s not working either.

    I recently upgraded all my blogs to WP3.7. All my other blogs are working fine. This one was too until I started getting this error.

    I really need to get into my blog urgently. I can’t afford any more downtime. So please if anyone else has any other suggestions/things I could try. Thank you.

    @chillysky What is your wordpress URL and site URL set to in your dashboard? if you have it set to http://www.domain.com then you need to make sure www is at the beginning of your login url, i.e., http://www.domain.com/wp-login.php

    If you do not have www set in your dashboard, make sure it is not in your login URL when you try to login.

    Does that make any difference?

    @chillysky there are many documented cases of this issue starting with the upgrade to 3.7.1. Is this by chance when you first noticed it?

    Cam
    Member

    @crazycoolcam

    @chillysky — Adding to @amsgator‘s note:
    If you’ve updated to 3.7, did your blogs work then, and if so, have your blogs by chance been auto-updated to 3.7.1? It may have happened automatically, and you may have received an email about it.

    Just trying to determine if this issue is 3.7 specific that becomes amplified by 3.7.1, or something that is exclusive to 3.7.1.

    ~Cam

    Hey @amsgator @cam, thanks for popping over.

    I reinstalled my WP earlier, still on 3.7 and now it’s showing me the dreaded white screen whether or not I have www in front. Before this, I only got the white screen when I commented out lines 744-746 in wp-login.php. I removed those when I reinstalled and now I’m only getting the white screen.

    No email and last I checked, I’m still on 3.7. I never upgraded to 3.7.1 at any time. Baffling!

    EmeraldCityEDM
    Member

    @emeraldcityedm

    Same issue here ,renaming the plugins folder via ftp worked for me – it is definitely a plugin causing this issue.

    I had encountered the same problem! Renaming the plugins via ftp worked for me too. Renaming it back to the original name then made it stopped working again. Hence I first renamed the plugin folder to allow me to login, then tried deactivating each plugin one by one. I found that the problem was caused by “AlphaOmega Captcha & Anti-Spam Filter”. Once I deactivated it, everything went back to normal.

    minxymoggy
    Member

    @minxymoggy

    I had the same problem on one site and many others that were fine. I found that it was a plugin issue too, although not before I wasted an afternoon trying to edit code in wp-login.php, which only resulted in a white screen.

    Here’s how I did this:

    1 – rename plugins folder via FTP
    2 – login to Admin
    3 – rename plugins folder back to plugins. As you’re already logged in it does not kick you out
    4 – Make sure you have another user ID with admin login. If you don’t create one now
    5 – Enable one of the plugins
    6 – In a separate browser, try logging in with you other ID. If it works, log back out, switch browser and enable the next plugin. If it doesn’t work you just found the plugin causing the problem.

    If you do not have FTP access, there is an alternative way to disable plugins by accessing your database through phpMyAdmin. Ask Google for full details.

    On the site that was having this issue, the conflict was with a Twitter Widget App. It seems quite possible that plugins which are duplicating functionality provided by Automattic are likely to get this as my plugin was like functionality that Jetpack has started to provide and Wiwiana’s sounds like an overlap with either Jetpack and/or Akismet, both of which are Automattic products. This might explain why I have only experienced this error on one site when I have many sites powered by WordPress. Just thought I’d drop this here as it is a nuisance bug that could easily ruin your day!

    PuzzlesFrustrateAndDelight
    Member

    @puzzlesfrustrateanddelight

    Hi Y’all,

    Here’s the fix. It may work for some. It may work for all. It worked for me.

    Open your saved passwords (Firefox for me). Find the saved password that has a www in front of it and delete it. Record it somewhere first, in case you need it later.

    Next, clear the data in your wordpress login box and try again, using the extension http://url.com without the www in front. By that, I mean the url showing in your saved passwords folder for the browser that you are using. This got me in every time. Yet, when I used the one with the www in front of it, it told me the password was incorrect.

    Yet, that’s not what the trouble screen tells you. It tells you that the cookies are blocked. Not so, as I cleared the cache and cookies and I don’t use a proxy server either.

    Hope this clears things up for some or all of you. WordPress please take a look at your security settings script and maybe you can do this before giving us an update, as I had a working site before thinking I was doing the right thing before updating. Lost time hits our pockets. On the plus side, thanks for providing us with a free platform. We have to praise, can’t just knock eh!

    Kind Regards

    WordPress Lover (most of the time lol)

    konceptunit
    Member

    @konceptunit

    Hey!

    this bug was driving me crazy the last couple of days so i thought after fixing it to share with you guys! the problem was when i was trying to login into my wordpress backend i got this annoying cookies error so this is how i fixed it!

    1. Go to your ftp and your domain.
    2. Afterwards go to your wp-contents
    3. Go to your themes folder
    4. Chose the theme that is active
    5. Look for functions.php of your teem and open it
    6. At the ende of the code you should see closing tag p> just remove it clear the spaces also and save it!
    7. Go to your domain.com/wp-login.php
    8. and try to login it should be fixed afterwards you can put the tag back where it was and save it again that was the solution for me this trick also fixes the white page problem in wordpress

    Cheers!

    abaco1944
    Member

    @abaco1944

    I had the same problem with 3.71 and now I have this problem with 3.9 the login page opens with https://domain.name.com then after Username and password and Captcha are input it then opens another page with https://www.domain.name.com showing the error of cookies are blocked.

    Can anyone help.

    jayant.jain904
    Member

    @jayantjain904

    Take out the below statement from login widget. This will help you…
    <input type=”hidden” name=”testcookie” value=”1″ />

    Awesome, this last one!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Can't login – Error: Cookies are blocked…’ is closed to new replies.