Can't login (Error cookies are blocked) (5 posts)

  1. NorthBlast
    Posted 2 years ago #

    Hey guys,

    I have been looking around online for a fix to this problem for the past 2 hours and all the solutions I have seen haven't work for me yet, thats why I decide to do the post.

    First, is the first time using WordPress, I was using dropplets for my blogging but I decided to check out wordpress to see how this one works.

    Well, I installed my wordpress in my hosting server last night and did all the steps on the installation guide. I got my database and everything setup.. but when I try to login happens this error, checked of course in different browser and checked my browsers settings and everything seems to be fine from that end.

    I have this on my wp-login.php

    //Set a cookie now to see if they are supported by the browser.
    setcookie(TEST_COOKIE, 'WP Cookie check', 0, COOKIEPATH, COOKIE_DOMAIN);
    	setcookie(TEST_COOKIE, 'WP Cookie check', 0, SITECOOKIEPATH, COOKIE_DOMAIN);

    which seems to be how it should be based on other posts, I also contacted my Host which is 000webhost and they said that from their end, they can only give me support for my sever that is up and running and not for coding or script support because I don't have a premium account..

    Well, anyways, I also saw this post if ( (!(req.url ~ "(wp-(login|admin)|login)")) ) { Which, I kinda barely understood because they don't say where this code should be or is within the files.. I also, must say that Im using whatever theme is enabled by default after the installation of the wordpress.

    Well, I hope someone can provide some help and know the fix to the problem, if you guys need more info or something more specific please let me know, I really wanna give it a try to this blogging service.

    Thanks! :)

  2. Tara
    Volunteer Moderator
    Posted 2 years ago #

    I think it's more like to be a server sessions or cookie issue. Have you spoken to your hosts about it. Or checked your error logs?

  3. NorthBlast
    Posted 2 years ago #

    @Tara yah I have. I already contacted them about it and gave my answer in the post.

  4. NorthBlast
    Posted 2 years ago #

    I fixed with this on my wp-config.php

    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', '');
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');

    Finally working.. I just logged in for the first time tho..

    got from this post here!

  5. Tara
    Volunteer Moderator
    Posted 2 years ago #

    glad you got it resolved :)

Topic Closed

This topic has been closed to new replies.

About this Topic