Support » How-To and Troubleshooting » Can’t login (blank wp-config.php)

Can’t login (blank wp-config.php)

Viewing 15 replies - 1 through 15 (of 21 total)
  • Keilya


    I don’t understand what you mean by a blank wp-config.php? As in it is blank when you open the file with a text editor? In that case, it shouldn’t be blank. Redownload the WP package and look for wp-config-sample.php. Fill in the details and save it was wp-config.php and uploaded it back to your server.

    It doesn’t hurt to delete plugins file off the server to see if it helps. (: Back up those files first of course!

    What I mean is that when I try to login to the admin console the page (whp-config.php) appears entirely blank in the browser. The file itself, viewed through a text editor, looks the same as it did before. I’ll download a new copy and enter my details, and then upload that to see if it doesn’t fix the problem. Thanks for the help, I’ll post and see how it goes.



    WAIT a minute lol. wp-config.php is NOT supposed to viewable through a mere browser! If it is, there’ll be serious security breaches. Why would you want to view wp-config.php from your browser anyway? Or is your login directing you to wp-config.php?

    it’s not viewable through the browser, but it halts on that php script instead of proceeding to the admin area. I’m not trying to view wp-config.php through the browser, I’m trying to log in. Sorry if I wasn’t clear-

    Sounds like WP isn’t installed, which is weird because your post sounds like you *had* a blog until just recently. Can we have a link to your broken site please? I don’t understand myself why wp-config.php is coming up anywhere UNLESS WP thinks that it’s not installed. And even if that were the case, it should then prompt you to click a link to install. Somehow your original wp-config.php file was hosed. Hopefully you have a backup or at least can populate that file with the necessary database information. 🙁

    Yeah, the link to the site is:


    Everything else appears to be working fine, I just cannot login.

    The wp-config.php looks accurate and is identical to the backup I created when there were no problems. I’m (backing up and then) deleting all of the plugins to see if that doesn’t fix it.

    I tried to register and it sent me a password. I tried to login and got a completely blank screen. I took a peek at the source code and you have a lot of jqueries going on there. So I tried loading the site in Opera instead of IE. And I got the same behavior. Really weird.

    And yes, you are correct to assume that sometimes it’s that oddball plugin that will make the site behave badly. And sometimes that’s the last thing we think of.

    BUT no need to back them up and delete them. Just rename the /plugins folder and see if that brings the site back up. Good luck with it, hope you sort it out.


    i have the same problem..
    my webpage http://www.vandijkmediaproducties.nl is on the air,
    but i cant login of change…


    Henri… is this a new install or an existing blog? Have you installed any plugins or tried to upgrade WP just prior to this inability to login?

    Hey guys, I’m new here but to me it sounds like

    A) you mean you can’t login to the wp-admin and not wp-config
    B)You are behind a router thats running the same server.
    I only get a blank screen when I look at my site when im in my own network.

    I think A) is accurate – cannot login to wp-admin. During the login process, after login information is entered, it halts on a blank page with wp-config.php in the address bar.

    I tried renaming the plugins folder through FTP, now when I try to login it gives me these errors on wp-login.php:

    Warning: Cannot modify header information - headers already sent by (output started at /home/djcharl/public_html/log/wp-config.php:57) in /home/djcharl/public_html/log/wp-login.php on line 202
    Warning: Cannot modify header information - headers already sent by (output started at /home/djcharl/public_html/log/wp-config.php:57) in /home/djcharl/public_html/log/wp-login.php on line 214
    Warning: Cannot modify header information - headers already sent by (output started at /home/djcharl/public_html/log/wp-config.php:57) in /home/djcharl/public_html/log/wp-includes/pluggable.php on line 552
    Warning: Cannot modify header information - headers already sent by (output started at /home/djcharl/public_html/log/wp-config.php:57) in /home/djcharl/public_html/log/wp-includes/pluggable.php on line 689

    I’m having the same problem… Don’t know what else to do…

    any suggestions aside from reinstalling?

    Looks like there is output in the wp-config.php file. This file shouldn’t display anything…check to make sure there aren’t spaces and line breaks outside of the PHP tags (<?php ?>) as this will cause the headers already sent error when wp-login tries to set session stuff.

    Nothing in the tags should print or echo either.

    An ugly hack would be to turn off error reporting but it would be best to just find the problem.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Can’t login (blank wp-config.php)’ is closed to new replies.