Can't login as admin to new blog because "cookies are blocked"; but they aren't! (3 posts)

  1. qpqpqp
    Posted 8 years ago #

    I just started a new WordPress blog (v. 2.3.3) on my own domain. I had some trouble with the database at first but eventually got it installed, got the "Success" screen, and the blog is now online and running.

    HOWEVER, I can't do anything to it because it won't let me log in as admin! When I try, and type in the correct username and password, I always get the same error message:

    "ERROR: WordPress requires Cookies but your browser does not support them or they are blocked."

    But that is completely not true! First of all, I have "Always allow cookies" as my browser setting. Secondly, I tried it in Safari, Firefox, and Internet Explorer -- all with cookies allowed, all the latest versions -- and got the exact same error message in every one, no matter how many times I tried.

    How can I fix this glitch, and successfully log in?

    Thee is a second problem, that isn't exactly related, but I'll mention it here in case it has some relevance to the login issue: The default front page of the new blog is kinda screwed up, in that I can see a mass of jumbled characters where the header and footer should be, and the formatting is all awry, and the default "kubrick" theme doesn't really appear properly.

    I'm hoping to fix all that once I log in!

  2. qpqpqp
    Posted 8 years ago #

    And yes, I browsed through all the previous threads about this "cookie" issue, and could never uncover a clear solution to the problem. A lot of discussion, but what was the final answer? I couldn't find it. What IS the current status of this issue? Do I have to uninstall and start all over again with an earlier version of WordPress because this one doesn't work? Or....?

  3. qpqpqp
    Posted 8 years ago #

    Oh, also, I tried the "patched" version of the "wp-login.php" file suggested by Ryan, but after uploading it, the problem persisted. So I went back to the original normal 2.3.3 version. I also was going to try pasting in the secret fix mention in "sitecookie.diff", but I see that it was already incorporated in the existed 2.3.3 wp-login.php, so that didn't work either.

    Still no solution? How can that be?

Topic Closed

This topic has been closed to new replies.

About this Topic